Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage
  • Community
  • Products
  • Bitbucket
  • Questions
  • SourceTree: how do i fix this error when submitting a pull request: "You don't have any remotes which have extended integration settings configured"

SourceTree: how do i fix this error when submitting a pull request: "You don't have any remotes which have extended integration settings configured"

From the menu I select Repository, then Create Pull Request. It displays this dialog box:

image2015-12-9 15:46:37.png

Bitbucket is hosting my repository.

5 answers

1 accepted

19 votes
Answer accepted

Found it.
Click the settings gear icon from the top right of the screen.
The 'Repository Settings' window is presented. Select your remote repository and press 'edit'.
The 'Remote Details' window is presented. Update:
URL / Path: update it to your remote git repo.
Set Host Type. In my case, it was 'Stash'.
Host URL: set it to my internal Bit Bucket host: http://bitbucket
Username: <your username>
This seems redundant since very similar data was alread entered in the 'Edit Hosting Account' window in my earlier comments.

Thanks for posting the answer you found.

For me this (unchecking and resetting the external server in the remote details window) solved.

Like # people like this

Tq its working now 

This resolves the pain killing red exclamation mark flashing up in your face when using SourceTree, thanks for sharing the findings!

 

/Peter

Thank you ! 

For me... my "Remote Account" was set to Generic Account.  When I switch it to my account, then the Pull Request went through and took me directly to the Bitbucket web interface.

UPDATE: Unfortunately, it doesn't seem to remember this change.  Everytime I launch Sourcetree, it reverts back to Generic Account.

Like joao_pedro_reis likes this

I have the same problem, also, I cannot click Edit or Sourcetree will crash as well.

It works on the first add, but once I close and re-open ST, the crash is persistent.

I had this error appear randomly when it had been working for me before.

Here is the solution that worked for me:

On the settings page just remove the current remote that is there and then add the exact same one again. This must have refreshed it / woke it up and now I have no probelms :)

thanks, this method worked for me. had this issue after updating to the latest version

Thanks. The same "refresh" worked for me as well.

Cheers,  a nice simple fix.

Second this. Deleting and re-adding the same remote worked for me.

Like Craig Stenseth likes this

This works for me as well until I close out Sourcetree, then the same problem persists.

The problem has been fixed in the latest version.

You have to set up your repo using the "Browse hosted projects" button in the Clone Repository dialog. This should enable Bitbucket's extended integration, including features like Pull Requests.

Thanks @Seth! I'm using SourceTree Version 1.6.21.0. I think I found a similar button from the main screen after my repository is cloned. On mouse over, the button says: "Show Hosted Repositories". When I click it displays the 'Hosted Repositories" window. From here, I select the row containing the repository I have cloned and press the 'Edit Accounts...' button. This displays the "Hosted Account List". I see the columns Host, Username, Show Private and Protocol. There is one row with the data "Stash", "kjohnso2", "True" and "HTTPS" respectively. If I press the "Edit" button, I see the "Edit Hosting Account" window. Hosting Service is set to "Bitbucket Server". Host URL is "http://bitbucket"; and Username is "kjohnso2". Login Status show a check and "Password OK". There is a list of "Projects to include" and the project containing my repository is in the list. The first time I explored this window, my password was not correct and the Hosting Service was "Bitbucket" which had a Host URL of http://bitbucket.org. I switched the Hosting Service to "Bitbucket Server" and our internal BitBucket URL and set the password. That felt like progress, but after all that I still get the same error when trying to initiate a pull request. I tried cloning my repository again and I think I found the button you mentioned. It is has a globe icon on it. It displays the 'Hosted Repositories' window and I select my hosted repository. Unfortunately, it places an invalid source path URL and the clone button is de-activated.

In case anyone else runs into this problem with Github, like I did...

Some of my repo directories were just fine, but a few of them weren't. After comparing the Settings within Sourcetree, I noticed that sometimes when Github is configured in the 'Remote Details' screen mentioned above, the URL for the working repos was set to https://www.github.com. The incorrect repos had it listed as an uneditable field: https://github.com. After grepping, I came across the file .git/sourcetreeconfig.

I copied the relevant lines in that file over from a working directory:

remoteProjectLink0.identifier=MyOrganization/repoName
remoteProjectLink0.username=myUserName
remoteProjectLink0.baseUrl=https://www.github.com
remoteProjectLink0.remoteName=origin

And now it works.

I don't have any of those settings in my sourcetreeconfig

Where should I be putting the code?

 

 <?xml version="1.0"?>
<RepositoryCustomSettings xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<AutoRefresh>true</AutoRefresh>
<AutoRefreshRemotes>true</AutoRefreshRemotes>
<DraftCommitMsg />
<IncomingSavedCount>0</IncomingSavedCount>
<LastCheckedRemotes>2018-06-01T08:02:53.4757963+10:00</LastCheckedRemotes>
<LastUsedView>Log</LastUsedView>
<LogBranchFilterIndex>0</LogBranchFilterIndex>
<OutgoingSavedCount>1</OutgoingSavedCount>
<SidebarExpandedItems>
<string>File Status</string>
<string>Branches</string>
</SidebarExpandedItems>
<SidebarWidth>210</SidebarWidth>
<SubtreeLinks />
</RepositoryCustomSettings>
0 votes
Rosa I'm New Here Mar 29, 2021

I counldn't solve it with any of the suggestions above.

For me it was an Update problem:

I updated Sourcetree to the latest version in Tools>Options > Updates > Check for updates. Then closed and reopened Sourcetree and problem solve! I was able to do the Pull Request.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Calling any interview participants for Bitbucket Data Center

Hi everyone,  We are looking to learn more about development teams’ workflows and pain points, especially around DevOps, integrations, administration, scale, security, and the related challeng...

442 views 4 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you