Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Cannot create PR (You don't have any remotes which have extended integration settings configured)

I get this error:

 

"You don't have any remotes which have extended integration settings configured, you need to edit your remotes to add details such as the hosting type and base URL. Click the settings button to open your remote list"

2018-02-21 17_01_58-Sourcetree.png

This is in SourceTree 2.4.8.0.

 

Where do I set the url for the PRs?

3 answers

I just can confirm that pr creation from sourcetree to Github stopped from working. Even editing the remote settings does not change anything. I see the blue progress bar but the browser is not opened.

I have the same problem, cant create any pull request using sourcetree. I always get the message of missing configuration, doesn't matter what is set there. Using the 3.4.1 version of Sourcetree.

Any ideas i could do here.

Pull.pngpull2.png

I have the same proble, Reverted to 3.3.9 (only version I had in my appdata)

Like Will Nguyen likes this

I had to revert to 3.3.9 too and it seems to have fixed the issue.

Like Will Nguyen likes this
0 votes
Mike Corsaro Atlassian Team Feb 21, 2018

Hello! Here's how to set the extended integration settings:

extended.PNG

 

Once you hit "Edit" you'll see the options to set the Host Type and URL.

Like Sandeep Mukherjee likes this

It already has the settings above (i could not add text after I inserted the image so i need to reply twice)

 

What else should i do?

Mike Corsaro Atlassian Team Feb 22, 2018

If the settings are correct (ST tries to automatically fill them out), then could you try again and see if it works?

i didn't change anything about the settings. They are like that in the screenshot. But it isn't working.

 

 

update: i selected Unknown in the dropdown and then selected Bitbucket again. This has probably reset the configuration, because now I can create a PR from SourceTree again.

Like # people like this

This worked for me as well. 

I get this error occasionally. Just clicking OK in remote information gets it working again for a while. It is annoying to have to keep going into the settings and clicking OK when I don't change anything.

Like Denis Glagolev likes this

I'm using GitHub and what worked for me was: select Unknown, save, select Bitbucket, save (which removes my GitHub userid), then select GitHub again and fill out my userid. I can now create a PR from SourceTreee.

Thanks, Greg.

Weirdly, that seemed to work for me too

On Host Type, just unselect and reselect and Save. It would work.

Like Subhashis Khatua likes this

"update: i selected Unknown in the dropdown and then selected Bitbucket again. This has probably reset the configuration, because now I can create a PR from SourceTree again."

^^ It's always the simple ones that do it :D

Thank you

I have the same problem: right click on a branch name > "Create pull request..." and then I get the message above. The repo is on Github. When I open the repository settings window and click "Ok" to save the settings I can go on and create the pull request but every time I close sourcetree the same issue appears again - for each and every repo I manage with Sourcetree it is the same so every day I start I need to save the repository settings before I can create pull requests from within Sourcetree.

 

Additionally on the "Remote" button there is a red icon on the "Remote" button.

screenshot.PNG

When I click there I see this message "Unable to open your web browser to '...', do you have your web browser set?" 

screenshot2.PNG

But it makes no sense as the black part in the screenshot shows an URL in the form "git@github:..." which should not be opened in a browser?! When I save the repository settings as mentioned above the red icon disappears and clicking on the button "Remote" opens the github project page in my browser. This happens also every time I close sourcetree.

I use to face the same issue multiple times. Just edit the config, and save it without any change (if your credentials are okay). I will work

Yes, but I have to do this everytime Sourcetree was closed and re-opened. At least every day. It seems to me that something is not working as it should.

Unfortunately I have tried all the above methods and am only able to create the Pull Request after the first time I add the remote. Once I close out Sourcetree, I have to delete the remote settings and re-add them. 

I've resorted to just doing my pull requests on GitHub directly.

As a note: I have tried PR to Bitbucket and GitHub both with success only on the first add. I have tried to open the configuration files and verify they are the same after the first run. 

The error is always relating to one's that have existed in the past and have been marked fixed, however, we are using the latest versions and are still getting the same null object exceptions.

Like Binbin Song likes this

I found the work to work with pull request and created a lesson about here

https://youtu.be/O1ka45DjNO4

Hey Gerd,

That is the exact work flow we are using now (except with Github) because the 'Create Pull Request' option under a branch would cause a crash.

 

image.png

 

The pull request would show a messaging saying no repositories exist and if you tried to edit any of the repositories Sourcetree would crash.


As of Sourcetree 3.4.3 the crash is no longer happening!

I see you left some of the original messages, so you know the problem! Try to install 3.4.3 and the problem should be resolved, and you should be able to do Pull Requests again from Sourcetree :)

I can confirm... for whatever reason Sourcetree did no update and no information was shown that there is an update, I had to download the version 3.4.3 manually. After that I needed to edit the repo settings once as described above but after a new start of sourctree everything is working now as expected

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

4,420 views 4 8
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you