Pipelines failing for a laravel repo, once successfully ran

I have a laravel repo and it's pipelines used to run successfully but at one point started failing and are now failing everytime since. When I run the pipelines, it gets to the  ```composer install``` section and everything goes fine until the end where I get this:

```phpunit/phpunit-mock-objects suggests installing ext-soap ```(*)phpunit/phpunit suggests installing phpunit/php-invoker ```(~1.1)phpspec/phpspec suggests installing phpspec/nyan-```formatters (~1.0 – Adds Nyan formatters)Writing lock ```fileGenerating autoload files> php artisan clear-compiled

``` [PDOException] could not find driver Script php artisan clear-```compiled handling the post-update-cmd event returned with error ```code 1

 

I've checked config.php and default connection there is mysql, also in the .env file my DB2_HOST has the correct IP address. 

 

Could this be on the bitbucket side?

1 answer

0 votes

Hey @hu,

I'm not entirely sure what's happening based upon your description, my first guess would be that a system package was updated or that the docker image was changed.

If you're still experiencing issues, please reach out to us via https://getsupport.atlassian.com

 

thanks,

Seb

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 06, 2018 in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

700 views 5 10
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you