Need help with git svn clone

Hi everyone...  I've got an SVN Repository that has many different unrelated projects in the trunk and I'm trying to clone each project into it's own bitbucket/git repository.  I followed the migration guide from Atlassian (https://www.atlassian.com/git/tutorials/migrating-overview) but I seem to be running into some trouble.

I downloaded and installed all the required tools in Ubuntu and then downloaded the svn migration script.  I was able to build the authors.txt file no problem but when I tried to run the next step (Convert) nothing seems to happen.

Here is what I am running:

~$ git svn clone --stdlayout --authors-file=authors.txt "https://core-wsus.cgc.local:8443/svn/NEW/trunk/CGC/AssessmentUploader SqlServer" assessment-uploader

 And here is the output:

Initialized empty Git repository in /home/ssmic/GitMigration/assessment-uploader/.git/
Using higher level of URL: https://core-wsus.cgc.local:8443/svn/NEW/trunk/CGC/AssessmentUploader SqlServer => https://core-wsus.cgc.local:8443/svn/NEW
W: Ignoring error from SVN, path probably does not exist: (160013): Filesystem has no item: File not found: revision 100, path '/trunk/CGC/AssessmentUploader SqlServer'
W: Do not be alarmed at the above message git-svn is just searching aggressively for old history.
This may take a while on large repositories

However when I view the output directory it is empty aside from a .git folder.  What am I missing here?

4 answers

This widget could not be displayed.

Samuel, it's normal for git to use a <repository>/.git folder to hold the entire repository, and then use the parent of that as the working tree. If the method does not check out a working tree, you'll end up with an empty folder containing only the .git folder, in which case you should be able to git checkout a working tree.

This widget could not be displayed.

So I need to cd into the newly created project folder (in this case assessment-uploader) and then run

$git checkout

 

I did that... but there's still no source?

Hi @Samuel Henderson, Did you manage to solve this?

This widget could not be displayed.

Hmm, in that case go back to the repository's container:

cd..
git clone &lt;repo&gt; &lt;newname&gt;
cd &lt;newname&gt;

Your new clone of the repo should have all of the data of the master copy, plus a working tree. 

This widget could not be displayed.

Hmmm Ok.  I tried that.  Here's what I got:

ssmic@bitbucket:~/GitMigration/assessment-uploader$ cd ..
ssmic@bitbucket:~/GitMigration$ git clone assessment-uploader assessment-uploader2
Cloning into 'assessment-uploader2'...
done.
warning: You appear to have cloned an empty repository.

I can confirm that the new directory is also empty.  

 

One thing I just thought of: when I initially did the git svn clone step I saw a message that disappeared saying "Checked through to r900" however our SVN Repository has over 3300 revisions

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Friday in Bitbucket

What is your #1 piece of advice to new users getting started using Bitbucket?

Hello Community! My name is Claire Maynard, and I’m a Product Marketing Manager on the Bitbucket team. I’m interested in hearing what advice or tips you have for new users getting started on ...

236 views 14 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you