MySQL GTIDs issue - can I downgrade from Bitbucket 5 to 4.14

Hi

With Bitbucket 5 there seem to be more and more issues we're experiencing when running on MySQL with GTIDs.


Do you know if it's possible do downgrade? Anyone done this?

 

Many thanks!

 

2 answers

0 votes

Well, strictly, yes, I know of one Bitbucket "downgrade".  Officially, it's not possible, and the mess we made while trying to do the downgrade strongly suggests that is mostly true.  It's hard work and goes wrong a lot.

If you are sure the problems you're getting are related to MySQL (and not just Bitbucket bugs), then it might be easier to look into migrating to PostGreSQL instead.

Thanks a lot Nic!

0 votes
Jeff Thomas Atlassian Team Sep 26, 2017

Hi Marcin,

In order to downgrade from Bitbucket Server 5.x to 4.14, you would need to restore both the database and Bitbucket Home directory to the previous state before the upgrade.

Also, just noting that using GTIDs in MySQL is not supported, more details can be found in BSERV-4964. Using GTIDs is known to cause various problems in Bitbucket Server (as you've likely already encountered). 

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Tuesday in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

166 views 3 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you