Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,295,937
Community Members
 
Community Events
165
Community Groups

Locked out of Bitbucket

Hi, I set up two-step authentication last year using the app Authy. However, I was away from work for a year and during this time I accidentally deleted Authy and the accounts it contained. So, now I have no way of logging into my account. Can you please help?

1 answer

0 votes
Mark C Atlassian Team Aug 16, 2021

Hi @saadan_sulehri ,

Thanks for reaching out to the community.

When you enabled 2FA in your Bitbucket Cloud account, I believe you've added an SSH key.
Would it be possible for you to use that SSH key then run the commands below to recover your Bitbucket Cloud account?

ssh git@bitbucket.org recovery_codes

Two-step verification - Atlassian Documentation

If you don't have your SSH key anymore, you can request a 2FA recovery email and within 24 hours you will receive the email so that you can disable your Bitbucket Cloud account's 2FA:

  1. Login to Bitbucket.org
  2. On the BB 2FA screen, click Forgot code?
  3. Click Send recovery email

Let me know how it goes.

Regards,
Mark C

Hi Mark, Thank you for your response. It is indeed helpful. I have one computer with the correct ssh key. However, unfortunately, I do not have physical access to that machine presently. And I have tried the recovery email solution about 3 times. The first time I tried it I was not able to open the recovery email that was sent after 24 hours. By the time I opened the email, it had expired. The next two tries I stayed on top of when I received the email but for some reason each link told me that my email link had expired. This is when I contacted the support team and the support team directed me to here. Any thoughts on what can be done about this? Perhaps, the support team can send me another recovery email and check on why my links are all coming through expired.

 

P.S. I already appreciate your promptness in replying but I am nearing a crucial deadline where I absolutely need access to the repo, so any way of expediting this will be very helpful and much appreciated.

Mark C Atlassian Team Aug 19, 2021

Hi @saadan_sulehri ,

Sorry to know that the 2FA recovery link is getting expired once you clicked it.

Would it be possible for you to check if your computer timezone is the same as the timezone you have in your Atlassian account? - https://id.atlassian.com/manage-profile/account-preferences
If not, would you be able to make sure it is the same?

I've also located the support ticket you've raised.
You should be able to receive the recovery email now.
Can you try to open the 2FA recovery link again?

Let me know how it goes.

Regards,
Mark C

Hi @Mark C ,

Thank you for responding. I checked the time zone and it is correct, so that is not the issue. And I have sent in the new recovery request as soon as I receive the new link I will check out if it works and keep you posted. Thanks again.

Mark C Atlassian Team Aug 25, 2021

Sure, let me know how it goes.

@Mark C ,

 

Thank you for your help. The link worked this time.

Like Mark C likes this
Mark C Atlassian Team Aug 29, 2021

Hi @saadan_sulehri

Great! Glad to know the link works now.

Regards,
Mark C

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS
Community showcase
Published in Bitbucket

Git push size limits are coming to Bitbucket Cloud starting April 4th, 2022

Beginning on April 4th, we will be implementing push limits. This means that your push cannot be completed if it is over 3.5 GB. If you do attempt to complete a push that is over 3.5 GB, it will fail...

2,170 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you