Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,462,160
Community Members
 
Community Events
176
Community Groups

I am unable to clone bit bucket repository from SourceTree

Edited

Error Message: 

FATAL ERROR: Server unexpectedly closed network connection

fatal: The remote end hung up unexpectedly

 

I am trying to clone using SSH protocol. Can someone please take a look and let me know what can be the solution?

1 answer

0 votes
Ana Retamal Atlassian Team Jul 29, 2019

Hi Mohammad,

We need to identify if the problem is coming from Sourcetree, or if there's any other issue trying to access the repo. For troubleshooting purposes, have you tried cloning your repository from the command line? You can find the instructions for this at Clone a repository. If the clone fails, that means there's something preventing you from connecting to the repo. If it succeeds, then it means something is failing between Sourcetree and your repository.

Let us know!

Ana

I am able to clone the repository using git command line.

Like eddie likes this
Ana Retamal Atlassian Team Aug 30, 2019

Thanks for your response, Mohammad. 

Can you confirm you added your SSH key to Sourcetree correctly? You can find the steps at Set up an SSH key.

If the SSH key has been added successfully and you're still having trouble, it could also be that there's something wrong with the server you are trying to connect to, or the network you are connecting over. Reading the logs on the server side will help, probably the system ones to see if the connection was severed or the service stopped.

Lastly, you can also have a look at the Sourcetree logs to see if the shed any more details. 

If after following these steps you're still having difficulties, please let us know the Sourcetree version and OS you're using so we can continue helping you.

Best regards,

Ana

Bkumari1 I'm New Here Jan 12, 2023

Hi I have tried everything and still unable to clone. My sourcetree version is 3.4.9

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events