Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,361
Community Members
 
Community Events
176
Community Groups

How to stop Bitbucket Server from using LDAP as Authentication?

A couple of months ago, I was trying to connect my Bitbucket server to an LDAP server on my network. This was just a test as I had never set up an LDAP server before this so I was trying to see what the process was like. I forgot to delete the LDAP connection and now when I try to log in to my Bitbucket server with the admin account I created during the initial install, it won't let me log in and has the error "Remote Authentication server is unavailable. Please try again later."

 

Doing my own research, I realize that i may have put my LDAP Authentication above the Internal User Directory which I assume is why it's trying to use the LDAP authentication over an internal account. I confirmed this by trying the Lockout Recovery solution found here: https://confluence.atlassian.com/bitbucketserver/lockout-recovery-process-776640158.html#:~:text=Start%20Bitbucket%20manually%20by%20running,Repair%20your%20configuration.

 

When running the start-bitbucket.bat file, the command prompt titled "Bitbucket Server" never continues after a certain point. However, with this command prompt open, I started the Atlassian Bitbucket service and tried to login with both the recovery_admin and my bitbucket admin account and I was able to capture the authentication log using LDAP in the command prompt. 

 

I also would like to point out that I do have a Jira server as well and I used to have an Application Link pointed to the Bitbucket server. However, the Bitbucket server's IP address changed, so I edited the Application Link to the correct IP address and I still wasn't able to login incase that was what was causing the issue as found here: https://community.atlassian.com/t5/Bitbucket-questions/The-remote-authentication-server-is-not-available-Please-try/qaq-p/611224 but did not work.

 

The other solution i tried was accessing my Postgre SQL database and running 

update cwd_directory set active='T' where id=32769;

found here: https://confluence.atlassian.com/bitbucketserverkb/cannot-login-to-bitbucket-server-using-external-user-account-after-moving-jira-crowd-server-779171395.html

This did not work either as it said "active" is not a column in "cwd_directory".

 

If all else fails, I will have to install a new Bitbucket instance from scratch and figure out a way to migrate the repositories to the new server instance which I would like to try and avoid.

1 answer

0 votes
Daniel Ebers Community Leader Jan 22, 2022

Hi @Justin Dye

welcome to the Atlassian Community.

I seem to have located some related information from knowledgebase but at this point I am unsure if they will match exactly your environment. You could clone the environment and test if the tips help - with a clone of your installation in a test environment.

https://community.atlassian.com/t5/Bitbucket-questions/remove-lira-user-directory-from-bitbucket/qaq-p/130173

This one seems being for Confluence, in a test you could check if it applies to Bitbucket as well:

https://confluence.atlassian.com/doc/reverting-from-crowd-or-jira-applications-to-internal-user-management-188086.html

Regards,
Daniel

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
7.6.0
TAGS

Atlassian Community Events