It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How many repositories can team account have?

When i try to create a repository, I recieve the next message

"All your team's repositories are already in this project".

Is there a number limited of repositories that team account can create

1 answer

2 votes

Hi Francisco! There's no limit to the number of repositories you can have into a Team account, the only limit is that every repo cannot exceed 2GB.

That message also does not really say anything about the account having reached a limit, so I'm not sure why you got it. Were you able to successfully create the new repo after all? If you're still having trouble, can you send me a screenshot of the error message and the name of the team, so I can have a look on our end?

Best regards!

Ana

Hi Ana,

I know that this is an older question but I ran into the same problem. I deleted an existing repository (3 are now left) and I get the same error message when I try to create a new one.

Any ideas?

Best regards,

Thomas

Hi @Thomas C. Focke! The previous user never responded so we don't know what happened in his case. The number of repositories created in an account should never be a problem, as you can have unlimited repos.

Can you explain a bit more about what you're doing and elaborate on how are you trying to create these repos? Can you also send a screenshot of when this happens?

Kind regards!

Ana

Hi Ana,

Thank you for your fast response.

I removed a team repository from this list:

Screenshot_20180327_155708.png

and if I try to add a new one, I get this error message:

Screenshot_20180327_155727.png

Best regards,

Thomas

Jim Redmond Atlassian Team Mar 27, 2018

This indicates that your team doesn't own any existing repositories that aren't in this project. You can still add as many new repositories to that project, as long as you create them first.

Thanks, James.

I was lost in translation. To "add" and to "create" are different functions.

Answer from Jim does not make sense at all and got the same issue. When I see such message the only thought I have is "WHAT? How can it be that team does not own repository in their project?".

Atlassian team, can you explain things properly?

Hi @Dmitry Tarasov, when you navigate to the 'Projects' menu and click on 'Add repositories', a menu will open to let you select repositories that already exist on that team and that can be added to that project. Let me illustrate this with an example.

These are the repositories that are currently part of my team project:

1.png

If I click on 'Add repositories' I can see there are still 4 other repos in my team that can be added to the project. Alternatively, I can add a repository from my individual account. Screen Shot 2019-01-15 at 10.04.23.png

 

If what you want is to create a new repository for that project, you need to create the repo first (like you would create any other repository for your team) and then come back to this menu and add it to the project like I've shown you in the screenshots.

Hope this clarifies, Dmitry! Let us know if you have any other questions and we'll be happy to help.

Cheers,

Ana 

Maybe the answer will be useful for other people: one cannot add repository into project using "add repository" button, instead you should click "+" in the left panel and it will allow you to add repositories. It still does not make sense for me, but solved the issue.

I got the same problem and land on this page, thanks @Ana Retamal Ortiz for the answer

That is indeed a convoluted way to understand, maybe the error message can be a little more explanative (like "If you want to add a new team repository, you first need to create a repository from an individual account and then you can add it to your team")

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published Mar 14, 2019 in Bitbucket Pipelines

Building a Bitbucket Pipe as a casual coder

...ipe.sh :  #!/bin/bash source "$(dirname "$0")/common.sh" enable_debug extra_args="" if [[ "${DEBUG}" == "true" ]]; then extra_args="--verbose" fi # mandatory variables R...

1,014 views 1 16
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you