Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,366,303
Community Members
 
Community Events
168
Community Groups

Git Push is failing for repo with error: RPC failed; curl 56 OpenSSL SSL_read: Connection was reset,

I'm trying to migrate a repo from github to bit bucket, but I keep getting the error message:

 

error: RPC failed; curl 56 OpenSSL SSL_read: Connection was reset, errno 10054
send-pack: unexpected disconnect while reading sideband packet
fatal: the remote end hung up unexpectedly
Everything up-to-date. 

 

I increased the buffer size after the suggestion said maybe the buffer was too small. I've also upgraded Git for Windows to the latest, made sure my connection is strong, rebooted. I don't have anti-virus. Other repos worked. The repo I'm trying to move is only 210 MB in size.

1 answer

0 votes

Hi @Joel Black ,

your issue is similar to this thread https://community.atlassian.com/t5/Bitbucket-questions/RPC-failed-curl-56-OpenSSL-SSL-read-Connection-was-reset-errno/qaq-p/1557220

Please take a look there to fix your issue.

Hope this helps,

Fabio

This did not help. I followed that guidance before I posted this. I created a workaround by copying my original git repo, cloning the new, empty bit bucket one, and copying over files in sets of fewer than 20. Each successive check in was small enough to avoid the error, but there is still no resolution to git pushing 250 MB to bitbucket. 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events