Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

GIT LFS- fatal: the remote end hung up unexpected

Hi,

we are facing an issue when checking out branches of a git repository hosted on the bitbucket cloud instance

Cloning into 'MFS999PF'...
remote: Counting objects: 53, done.
remote: Compressing objects: 100% (50/50), done.
remote: Total 53 (delta 5), reused 0 (delta 0)
Receiving objects: 100% (53/53), 6.59 KiB | 249.00 KiB/s, done.
Resolving deltas: 100% (5/5), done.
fatal: the remote end hung up unexpectedly
warning: Clone succeeded, but checkout failed.
You can inspect what was checked out with 'git status'
and retry with 'git restore --source=HEAD :/'

 

we already tried "git restore --source=HEAD :/'" without success (same error)

It's a repository containing LFS and it seems that the issue is around this feature as we do not have any problems cloning/checking-out any other repositories.

The error appears between January the 14th and the end of january, before this date checking-out branches was working fine and nothing was changed on the client computer during this period.


Does anything change on the cloud instance on these dates ?

We used git 2.30.1

If anybody can help...

Thanks

 

1 answer

0 votes

Hi @Neovia-IT Administrator ,

1) The output that you posted here looks to be from a clone command. Are you facing this issue both when you take a fresh clone, and when you check out branches in an existing clone?

2) Do you get the same error if you try to clone this specific repo from a different computer? I am asking so we can narrow down whether the issue may be related to the LFS configuration/installation of this specific computer or not.

3) What is the version of Git LFS on the computer where you see this issue? You can check that with the command

git lfs version

If it is not the latest version, mentioned here: https://git-lfs.github.com/, can you try upgrading Git LFS to the latest version, and check if the problem still occurs?

Kind regards,
Theodora

Hi @Theodora Boudale

1) Yes, we have a same issue both when you take a fresh clone, and when you check out branches in an existing clone.

2) Indeed, we encounter this issue on one computer and not on the others.

3) if I check the version by the properties of git LFS, we have the version 2.13.2.0 (last version).  When we type $ git lfs version by command, we have no result or no output in the console. We have the same thing for the other lfs command. (git lfs install, git lfs clone: no output).

 

Where can I find logs to get more informations?

 

Thanks and Regards

Hi @Neovia-IT Administrator ,

1. You mention

if I check the version by the properties of git LFS, we have the version 2.13.2.0 (last version).

It's a bit unclear to me where you check that, and what you mean by properties of Git LFS. Could you please explain where you see that, and/or attach a screenshot that shows where you see this?

2. Do you use Git from command line/Git Bash, or do you use some Git GUI client when cloning/committing/pulling/pushing to the repo? If you use a Git GUI client, could you please let me know which one?

3. In case you use a Git GUI client, do you open a console window from this application?
Or do you open it from your system? In case you open it from your system, could you let me know which one it is? E.g. Git Bash in Windows? Or Terminal in Mac? Or something else?

Kind regards,
Theodora

1. I checked the properties details by this path "C:\Program Files\Git\mingw64\bin\git-lfs.exe" (Windows) 

Git LFS Version.jpg

 

2/ 3 - I use gitExtension but tested with gitBash for Windows.

Git Bash Version.jpg

 

Thanks and Regards

Hi @Neovia-IT Administrator ,

Thank you for the info.

It seems strange that you get no output at all from the commands git lfs version and also git lfs install. This sounds like an issue with the local installation, my suggestion would be to try uninstalling Git Bash and install it again, and then try to install LFS again with git lfs install.

You mentioned that you use gitExtension, do you mean this tool http://gitextensions.github.io/ ?

I am not sure how this works with LFS, and whether it uses the LFS installation of your system or if there is an embedded version of Git LFS that comes with the tool. In the first case, if reinstalling Git Bash and Git LFS solves the issue from Git Bash, it will most likely solve it for gitExtension as well. If gitExtension uses some embedded version of Git LFS, you can look into whether it's possible to remove and reinstall that as well.

Kind regards,
Theodora

Hi @Theodora Boudale , 

We re-installed the latest version of git and by running git commands without using gitExtension, we can't retrieve projects that are in Git LFS on a machine. But we manage to retrieve the repositories on others.

Thanks and Regards

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,826 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you