Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
Level
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Firefox: attempting to login to my.atlassian.com produces endless page reload

4 things about me (some of which might not matter):

* longtime Bitbucket user
* I change passwords on important accounts (inc BB, now therefore Atlassian) with period ~= 90 days
* I webbrowse with Firefox, and am currently still on Firefox version=56 (i.e., pre-Quantum) waiting for an extension to upgrade
* I run OS=Linux distro=Debian version=8.9

To change pw, I browsed to https://my.atlassian.com and attempted to login using what I strongly believe to be my correct credentials (including ID=email). I then got redirected to

https://id.atlassian.com/login?application=mac&continue=https://my.atlassian.com&token=<alphanum string length=280/>

[loop top]

which attempted to redirect again, which produced the Firefox warning

> Firefox prevented this page from automatically redirecting to another page.

I hit button=Allow, which immediately reloaded the page, but returned me to top of loop.

[loop end]

After ~20 trips through loop, I websearched on term='Atlassian login reload', which returned (et al) some helpful-looking material from domain=atlassian.com. I took what seemed to be the most useful advice, which was to

1. dump cookies
2. dump cache
3. reload browser

I did this, then rebrowsed to https://my.atlassian.com , but observed no change: same infinite redirect/reload loop.

What to do? Meanwhile, will retry on another box with Quantum aka Firefox version >= 57.

14 answers

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

I'm stuck with an infinite loop in Firefox 73.0.

Also a long time Atlassian user.

I can login and view:

  • my.atlassian.com:
  • start.atlassian.com
  • id.atlassian.com/manage-profile/profile-and-visibility
  • bitbucket.org

Buy as soon as I try to access Confluence, my URL goes to id.atlassian.com/login? and I get the redirect problem and eventually I'm taken to:
mycompanyname.atlassian.net/login?redirectCount=3&dest-url=%2Fwiki...
and this error page appears:

Atlassian
mycompanyname.atlassian.net
Something has gone wrong

Check that your browser allows third-party cookies and then try again using the button below (without refreshing the page):
[ Try again ]

In Firefox I've tried turning off all Browser Privacy settings, allowed all tracking, allowed all trackers, etc. I cannot for the life of me access Confluence with Firefox.

This is really frustrating.

----

UPDATE! Problem found and fixed:

After a lot of testing I found that the problem was caused by the uMatrix Firefox add-on spoofing the Referer header.

I disabled Referer header spoofing for atlassian.net and atlassian.com, and now I can access Confluence.

Thanks Darian, this solved the issue for me as well.

Like Dustin van Schouwen likes this

I had the same redirect loop.  In my case the problem is Atlassian depending on http "referer" to allow login.  If it's spoofed like firefox can be configured to do, you get 403 errors and are redirected.  This would be consistent with it happening to some people only on Chrome, others only on Firefox.  Could be the underlying cause for most people experiencing this.

Referer is bad, relying on it is bad, and it adds nothing to security.  In fact forcing your users to  configure their browsers and firewalls to send it does a little of the opposite.  Please fix it some day.

Yes it's so weird and sucks

You might run into this issue:

https://community.atlassian.com/t5/Bitbucket-questions/Cannot-logon-to-Atlassian-website-using-Firefox-59/qaq-p/763999

read answer:  Pruthvi Sabbu Oct 03, 2018 • edited 

"Apparently, Atlassian is trying to fingerprint browser. And I have configured the browser to resist fingerprinting scripts and hence the issue. Once I have disabled the config privacy.resistFingerprinting, I am able to access the same. I really wish Atlassian stops tracking!"

2 votes
Andy Heinzer Atlassian Team May 24, 2019

Hi everyone,

Sorry to revive this old thread.  Just trying to determine if there are still any Firefox users out there that still can't login to https://my.atlassian.com

If so, could you please let me know what version of Firefox you currently using?

I also noted that @Pavol Liška came across a solution in his case in regards to a privacy.resistFingerprinting setting that was enabled in his browser.  This is something that you can change in the about:config settings of Firefox.  Details in About:config editor for Firefox.

"Apparently, Atlassian is trying to fingerprint browser. And I have configured the browser to resist fingerprinting scripts and hence the issue. Once I have disabled the config privacy.resistFingerprinting, I am able to access the same. I really wish Atlassian stops tracking!"

Curious to see if this helps, or if there are still outstanding problems here.

Thanks

Andy

There seems to be a new login screen, I no longer have the login problem.

Kudos to Andrew for a swift resolution...

Like # people like this

I am encountering this problem running Chromium 75 on Freebsd 12.

Firefox 67 works fine

Like Matthew Marsh likes this

Hi Andrew,

I am trying on Firefox 67.0.1 and am getting the endless page redirect (Something has gone wrong page that I can screenshot if you need). If I browse to https://id.atlassian.com  and try to login, it keeps endlessly redirecting to start.atlassian.com and just keeps repeating. I've tried all the troubleshooting in this thread so far and can confirm I can login using Chrome without issue. Is there any other information you need or anything else I can try?

 

**Edit**

After running some of the diagnostics suggested in this thread, I was able to figure out what was going on. Our content gateway was intercepting the traffic and Firefox was detecting this as a MITM attack. I added a static bypass for myself and was able to login without issue. I'm still doing some research on a long term solution, but figured it might help someone else experiencing a similar situation

**Edit**

 

Thanks,

Matt

I'm in an infinite login loop in Firefox 71

Are you seriously requesting that users give up on privacy so the login service may track the hell out of everyone?

No other service does this. Heck, not even Facebook requires fingerprinting for login.

Like Paul Nevin likes this

@Andy HeinzerI'm still having trouble with this. For months now I've had to open Safari to use certain products. AFAICT it's only affecting Confluence and Jira for me

If I go to id.atlassian.com I get redirected to start.atlassian.com which works, but trying to go Confluence and Jira results in the redirect error mentioned above.

 

I've tried:

  • Clearing all cookies (very frustrating)
  • Disabling all extensions
  • Toggling `privacy.resistFingerprinting` (it seems to be `false` by default now)
  • Disabling “Enhanced Tracking Protection”

This issues seems to have been going on for years. Can you please try to reproduce it locally?

 

Odin Dutton

Culture Amp

Still experiencing this on firefox 68.0.1 even in safe mode. 

@Andy Heinzer, is there any hope of getting any attention from Atlassian for this issue? There seems to be an ample number of people here willing to assist you in debugging the problem if that's what's holding you back.

Same issue using FireFox, latest update, Windows 10
I earlier today cleared my cache and cookies and ever since it will not let me log in 

Tried refreshing Firefox as suggested above but that hasn't worked.

It gets stuck at the same spot every time i.e login?redirectCount=3
Any help/advice please? Driving me nuts now.
 

Same problem, FF 63.

 

Tried to dump cache, cookies, add-ons, private browsing, fingerprinting, ...  The console shows content security policy warnings, but nothing else.

 

can login to id.atlassian.com and this site.

also see a deprecated cookie api warning in aui.js

I've got a full HAR file.  Don't know how to attach it here.  It's 4MB.

I can fix http 400 by playing with custom values in network.http.referer

 

I can't -- yet -- confirm default values in FF 63

wonder out loud:

are the security and referer policy headers getting stripped or mangled somewhere?

I have the same redirect issue on Brave Chrome and Safari on the same machine. Admin killed my account and reinvited me but that did not help. Reboot, Clear Cache, still no luck. 

Primarily using Brave. Shields are down which means 3rd party cookies and fingerprinting are enabled. To me, this seems to be a server-side problem. 

Same here, Brave simply does not work.  Shields are down, always have this problem.  Firefox on the same machine works fine.  

Got help from Atlasian, (it took some prodding I must say) you need to whitelist these domains, In Brave it's not enough use the site with Shields Down.

Go to:

brave://settings/content/cookies?search=cookies

Under Allow you need to add each of these sites (add them one at a time) 

https://atlassian.com

https://aui-cdn.atlassian.com

https://common-admin-cdn.atlassian.com

https://jira.comhttps://atlassian.io

https://atlassian.net

https://[your domain].atlassian.net 

You need to use the correct domain name in the last URL replace [your domain] with the domain of your company, organization whatever...

Like ryan_sutter_govdocs_com likes this

Thank you so much for this.  It worked.  

Has anyone successfully gotten this to work on Firefox?

Yes, delete all atlassian accounts and never go back

I have this issue - I cannot login to Bitbucket. I get redirected to:

https://bitbucket.org/socialauth/login/atlassianid/?next=%2F

This screen is blank.

I should mention this is on Firefox Developer edition 70.0b2....

I have the same problem on Firefox 75.0.

disabling privacy.resistFingerprinting does not help

0 votes
Andy Heinzer Atlassian Team Dec 11, 2017

Hi Tom,

Sorry to hear that there is a problem with logging into one of our sites.  I am interested to know if this only effects Firefox.  Is it possible to login to the site from this machine using another browse such as Chrome?

I suspect there might be another problem here though if that doesn't work.

Try going directly to https://id.atlassian.com and see if you can login directly to that site first.  If you can, I would suspect this page might take you to your profile page.   If you can login directly there, I would be interested to see if you can then use the same browser tab/session to then navigate directly to https://my.atlassian.com

and see if that works.

If you're still getting this stuck in an endless login loop, please let me know the the username/email address you are using to try to login to our site and I will launch an internal investigation to see if there is perhaps something wrong with your specific account that might be causing this problem.

Thanks,

Andy

Hi Andy, I have the same problem with looping if I try to switch apps from sidebar to HOME application. 

1. Open sidebar

2. Click to "HOME"

3. Confluence and JIRA software clouds instances react the same behaviour - application will start with some loop (https://id.atlassian.com/login?continue=https) and I cannot stop it or return to JIRA or confluence. 

 

Error_Switching_Home.png

Andy Heinzer Atlassian Team Jan 02, 2018

Hi John,

Is this problem happening for your in Firefox only?  I am curious to see if perhaps we can learn more about your environment to understand the scope of this problem better.

Also, does this effect other users in your environment?  Different browsers?   I would also be interested to learn about your specific Cloud URL.  I would like to try to reproduce this problem so we can better understand what might be causing this.  

So far I have not been able to recreate this problem yet.

OS X 10.11.6

Unable to login:

Getting the login loop using FF 69.0.2 

Unchecked all defaulT content blocking options and disabled all extensions and plugins.


Was able to login:

Using my google profile I could login using FF 69.0.2 

Could login using Vivaldi browser 2.4.1488.36using my chosen username and password 

Could login using Chrome browser 77.0.3865.90 username and password 

Hi Andy, I tested with new JIRA cloud instance and the behaviour is the same, but only with Chrome! I checked in IE11 and it works correctly. 

Problem with HOME and looping exists in Chrome. 

https://myjira.atlassian.net/home?src=appswitcher&ref=Jira

 

Please could you reproduce this problem. 

Thank you. 

Andy Heinzer Atlassian Team Jan 23, 2018

Hi @John Xolobo

So far, I have not been able to reproduce this problem.  Could you let me know more about your environment?  Are you also using a Linux OS, like Tom initially reported on this thread?

Could you let me know what specific versions of Firefox and Chrome you are using?

Have you tried to use the Private browsing mode or Incognito mode in either of these browsers?   I am curious to see if you can recreate this problem in these private browser modes to see if this is possibly related to a cookie/cache or possibly some other extension in the browser itself.

Hello, I have been having this same problem with both Firefox and Chrome on a Linux OS.  From what I can tell, this problem only exists when connecting from a Linux OS.

Hi,

I'm experiencing the same issue with Firefox 59.0.3 (64-bit) on Windows 10.

Chromium on the same machine works fine.

 

Update: Refreshing Firefox did the trick for me.

Further update: seemingly at random, the issue reappeared.

Andy Heinzer Atlassian Team May 16, 2018

I would be interested to see if anyone that can reproduce this problem could also generate a HAR file in their browser when this happens and then provide that HAR file to us for review.  Steps on how to do this differ depending on browser, but a general outside exists on Generating HAR files and analyzing web requests.  Perhaps we can learn more about this problem by looking at these session logs.

I've generated one on FF and Windows 10 with the issue.

I am still experiencing the same problem on WIN7 with FF6 61.0.1.

Have to change to Chrome to be able to login.

Like m3nda ler3nda likes this

Same here (again) on linux with FF 61.0.2

@Andy Heinzer, please let me know where to send the HAR.

I have similar issue.

Whenever I try to access my Atlassian domain(cloud) from Firefox I get redirect status response code.

I'm landing on https://id.atlassian.com/login?continue=https... (my Atlassian domain) where I try to login but I get the message "Something went wrong while attempting to validate your credentials.

This is happening with firefox, tried with Chrome and there is no issue.

Find the har file here

https://drive.google.com/file/d/1clYxTOrAGLoTGMfS3i4QTcHI1qUWzVdq/view?usp=sharing

Why is it only happening on Atlassian and no other sites? This caused my ff to hang

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

TAGS
Community showcase
Published in Bitbucket

Calling any interview participants for Bitbucket Data Center

Hi everyone,  We are looking to learn more about development teams’ workflows and pain points, especially around DevOps, integrations, administration, scale, security, and the related challeng...

485 views 5 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you