Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Error: RPC failed; curl 56 Failure when receiving data from the peer even if I set up proxy

zagoramaria
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
August 28, 2023

Hi,

I am trying to git clone a repository and I am receiving this error :

error: RPC failed; curl 56 Failure when receiving data from the peer

I have change the post buffer into a maximum variable but nothing.
Also, I have set up the proxy and http.sslBackend as schannel and when I run the command
GIT_TRACE_PACKET=1 GIT_TRACE=1 GIT_CURL_VERBOSE=1 I have ==>  Info: schannel: failed to decrypt data, need more data.

I do not know if it is relative issues.
Anyway, can you please help me ? I think I tried all possible solutions..


 

1 answer

0 votes
Patrik S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
August 29, 2023

Hello @zagoramaria and welcome to the Community!

As per what was discussed in a previous questions here in Community , setup the sslBackend as openssl seems to be a valid fix on an issue where a user received the same error message you shared.

In this case, could you please run the command below

git config --global http.sslBackend openssl

and then try running the clone again and check if it works ?

Let me know in case you have any questions.

Thank you, @zagoramaria !

Patrik S

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PERMISSIONS LEVEL
Site Admin
TAGS
AUG Leaders

Atlassian Community Events