Cannot login with Bitbucket in SourceTree after linking with Atlassian ID/Google

Hello

I cannot login on Bitbucket in SourceTree anymore. I have just completed the merge between my Bitbucket profile and Atlassian ID.

The important point is that I login to my Atlassian ID with my Google credentials, so no specific login/password.

I think the issue is due to SourceTree trying to connect with my previous Bitbucket login/password. I should probably provide the login/password used for my Atlassian ID, but since I am using Google "auto-login", I do not have them directly.

I have tried to set back a classic login process with Atlassian ID, but this not seems possible.

 

How to correctly setup Bitbucket in SourceTree in my situation ?

Or, how to remove Google login and revert to a standard login/password on Atlassian ID ?

 

Thank you in advance.

3 answers

1 accepted

1 vote

Hi Naëm,

Since one of the steps of the upgrade process was to input your Atlassian account password, you should now have a password set (in addition to being able to use Google). You should be able to use your Bitbucket username and Atlassian account password to authenticate SourceTree.

If you need to reset your Atlassian account password, you can do so here: https://id.atlassian.com/login/resetpassword

Thanks,

Alastair

I have a similar problem, can't login to Bitbucket Cloud from SourceTree because it won't accept my Bitbucket username and my Atlassian ID password.

I had another Bitbucket account that this was effecting, and I got it working by using the old Bitbucket password.

That's not possible for a new account now, you have to sign up with the Atlassian ID.

It is not possible to enter your Atlassian ID info into SourceTree, it specifically will not let you use an email address for a username.

How is this not a bigger problem for people?

Hi Michael,

I'm sorry you're experiencing issues authenticating in SourceTree. The behavior you're describing is strange! Are you able to log into Bitbucket Cloud using that password? If yes, but it's not working in SourceTree, can you send an email to support@bitbucket.org so we can investigate?

Thank you!

Alastair

I am experiencing the same issue. Is there any known fix for this?

To be clear: I am able to login on Bitbucket Cloud using my password but not in Sourcetree. I even tried changing the password and that did not work in Sourcetree, but again I could login with the new password on BitBucket Cloud. I double checked the username and it is correct. no Idea what is going on...

Also, i am having the same issue, any body can help us

Same issue. Can connect to bitbucket web but not with the source tree with the same credentials.

Have same issue. Driving me nuts.

Did either of you manage to resolve this issue? I have been having the same issue.

yes, me too , windows 7 professional 32 bit , sourcetree 2.7g , can login web , bitbucket and also atlassian account , but cannot login using sourcetree , even have gone to set the IE and make security to the lowest for all zones , any one found solutions ?

Rather use the previous version, which was working flawlessly.

I got it to work. I completely closed Git and SourceTree. I then when into Bitbucket as if to checkout my code. Instead of cloning in SourceTree, I used the Git command it suggested from the Terminal in SourceTree. It asked for my password and took it when I did this.

Hi , after so many tries ... until almost tempted to scream , finally , i check my internet explorer , it is ancient version 9 , i updated to version 11 and bingo ... everything work fine now .... have been a while since i CARE about the IE ! haha ... hope this help for those who are having problem signing in , in your windows 7 professional.

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

709 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot