Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,409,312
Community Members
 
Community Events
169
Community Groups

Can't commit due to encoding error.

Deleted user Dec 08, 2020

I've tried to do the welcome task to learn how to commit files.

It turns out I'm unable to do that. After clicking Commit a message pops up:

Failed to detect original file encoding. Cannot save commit with unknown encoding

 

No matter what text I paste I always get the same message.

3 answers

I had the same error and it appears that the encoding issue was in the filename field. This happened when I copy/pasted from the example which likely bought over non UTF-8 characters. Try clearing and then typing in the filename manually.

This worked. I changed the name of the file and then it fixed.

Like # people like this
0 votes

I solved it by editing the file locally and then pushed the code to the remote repository.
Now whenever you make any new change to the same file on the remote server you won't receive this error.

Deleted user Dec 09, 2020

I'm not sure how it is supposed to help me. They talk about a bug that is not yet fixed.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events