Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Bundled elasticsearch and nginx reverse proxy

Diego Peruselli
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
July 24, 2017

Hi everyone, I've searched the forum and google for hours but it seems I can't find an answer to my problem...

I've set up bitbucket server on my machine and tested it: everything ok.

The I've configured nginx to reverse proxy all the call to /bitbucket to the port :7990. Bitbucket it's working, I've followed the guide here on atlassian and changed the configuration BUT I have a yellow alert and an error on elasticsearch.

Before the proxy setup the test button was working, now it give me this message:

Something went wrong while trying to serve your request. Try reloading the page.

Looking in the log I get this when I press the button:

2017-07-24 15:43:23,747 WARN [http-nio-7990-exec-8] diego @1W6SZCDx943x23x0 htgxj6 127.0.0.1 "POST /rest/search-admin/latest/test-connection HTTP/1.0" c.a.p.r.c.s.j.XsrfResourceFilter Additional XSRF checks failed for request: http://localhost:7990/bitbucket/rest/search-admin/latest/test-connection , origin: null , referrer: http://MYSERVER/bitbucket/mvc/admin/server-settings , credentials in request: true , allowed via CORS: false

 I tried to set CORS in the in the elasticsearch.yml to no avail using this:

http.cors.enabled: true
http.cors.allow-origin: "/.*/"

 I always get the same error message.

What can I do?

The server is a fresh Debian 9 with nginx and postgres. Confluence and Jira are also installed but not behind the reverse proxy (for now).

 

Thank you in advance

3 answers

0 votes
David Schmidt November 2, 2023

Hi there, some years passed, but I am having the exact same error in a dockerized BB server, version 8.9.6

Opensearch is being used, it works when accessing BB without the proxy, but not when going through Nginx.

Any hint?

0 votes
Mike Ellertson July 31, 2019

I am experiencing what seems like the exact same issue.  Here's what I'm seeing.

bitbucket-issue.png

0 votes
Craig Castle-Mead
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
February 19, 2018

Hey Diego,

If you go to your Troubleshooting and Support tools page (https://bitbucket.mycompany.com/plugins/servlet/troubleshooting/view/) then Elasticsearch, what information is displayed?

You also mention a "yellow alert" on Elasticsearch - is that referring to the Elasticsearch cluster health itself (https://www.elastic.co/guide/en/elasticsearch/reference/current/cluster-health.html) or a Bitbucket health check against Elasticsearch such as on the /admin/server-settings page ?

CCM

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events