The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

Bitbucket path with special characters {} cause 400 error

Jingjing Li
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 15, 2021

Hi all,

 

One of our Atlassian Bitbucket repo has a folder/file named with {}.

These special characters are causing 400 error when trying to access the folder. 

 

But this is not an issue for Bitbucket cloud.

 

Is there anything we can do to allow these special characters? I could not find anything for Tomcat in the Bitbucket server

1 answer

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

0 votes
CATS Delivery Platform
October 24, 2022

Do you use a reverse proxy like nginx? In that case the info here might help to fix it: https://confluence.atlassian.com/confkb/pages-with-special-characters-are-not-accessible-via-reverse-proxy-829664257.html 

Gonchik Tsymzhitov
Community Champion
May 17, 2023

no luck

TAGS
AUG Leaders

Atlassian Community Events