Bitbucket behind a remote proxy

Hi

I moved my bitbucket server behind a remote proxy. The server is reached with

www.ipj-engineering.de/bitbucket

In the bitbucket daministration I set the Base URL tho the address "http://www.ipj-engineering.de/bitbucket"

But If I access bitbucket somthing is wrong: the Address is changing to the internal address of the server (192.168.100.11:7990). Also the "BitBucket" button shows as a address the internal address.

With Jira and confluence all works fine.

 

1 answer

1 accepted

0 votes
Accepted answer

Hi Peter,

Upon placing Bitbucket Server behind a proxy, you need to inform the application that is it behind a proxy so that it will address it's traffic accordingly.

If you are running Bitbucket 5.x+ you can accomplish this by adding the following variables to your $Bitbucket_Home/shared/bitbucket.properties file. You can find detailed instructions for using Nginx and
 HAProxy. Both of these guides show for ssl but you can simply use the below block instead of the bitbucket.properties block the documentation provides to maintain your non-ssl configuration.

server.port=7990
server.scheme=http
server.proxy-port=80
server.proxy-name=ipj-engineering.de
server.context-path=/bitbucket

If you are running a pre-5.0 version of Bitbucket you will need follow these guides for Apache, Nginx and HAProxy. In this case you will need to set the same variables but instead you will set them in the $Bitbucket_Home/shared/server.xml file as shown below.

<Connector port="7990" 
     protocol="HTTP/1.1"
     connectionTimeout="20000"
     useBodyEncodingForURI="true"
     redirectPort="80"
     compression="on"
     compressableMimeType="text/html,text/xml,text/plain,text/css,application/json,application/javascript,application/x-javascript"
     scheme="http"
     proxyName="ipj-engineering.de" 
     proxyPort="80" />
<Context path="/bitbucket"
docBase="${catalina.home}/atlassian-bitbucket"
reloadable="false"
useHttpOnly="true" />

Once you complete the appropriate configuration, you will need to restart Bitbucket and then simply re-set your baseUrl to ensure it takes effect. Administration > Server Settings, Enter your baseUrl of http://ipj-engineering.de/bitbucket and hit save.

Super working now

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 06, 2018 in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

402 views 5 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you