Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,295,633
Community Members
 
Community Events
165
Community Groups

BitBucket builds for Android are failing

I have been using BitBucket pipelines for sometime now and suddenly from yesterday builds have been failing with the following error

* What went wrong:
A problem occurred evaluating project ':app'.
> Failed to apply plugin 'com.android.internal.application'.
> Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8.
You can try some of the following options:
- changing the IDE settings.
- changing the JAVA_HOME environment variable.
- changing `org.gradle.java.home` in `gradle.properties`.
I am using Gradle version 7 / java 1.8 in my local machine builds and I am able to get the build done successfully. Not certain what is going wrong on the server builds. 

2 answers

`mingc/android-build-box` doesn't seem to have jenv install but it does have java 11. I solved it by prefixing $PATH with the java 11 path and setting JAVA_HOME as first steps in my pipeline.

 

     script:

             - export PATH=/usr/lib/jvm/java-1.11.0-openjdk-amd64/bin:$PATH

             - export JAVA_HOME=/usr/lib/jvm/java-1.11.0-openjdk-amd64/

Thank you @Jonas E , that solved my issue :-)

Still a bit mean that they mention jenv in the docs of the docker image, but then it is not recognized properly...

This happened to me to, after I've upgraded the projects gradle from 4.2.2 to 7.0.1

 

Any solutions yet?


I am using:

# Using docker image from: https://hub.docker.com/r/mingc/android-build-box/
image: mingc/android-build-box:latest

And they say with jenv you can change the version. But in my pipeline script "jenv" is not a recognized command and Bitbucket pipelines fails with:

+ jenv local 11

bash: jenv: command not found

 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Git push size limits are coming to Bitbucket Cloud starting April 4th, 2022

Beginning on April 4th, we will be implementing push limits. This means that your push cannot be completed if it is over 3.5 GB. If you do attempt to complete a push that is over 3.5 GB, it will fail...

2,170 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you