Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,293,938
Community Members
 
Community Events
165
Community Groups

BitBucket Pages - Repository Not Found

I created private repository for my static website by following the tutorial https://pages.bitbucket.io/ or https://confluence.atlassian.com/bitbucket/publishing-a-website-on-bitbucket-cloud-221449776.html?_ga=2.208755538.1113104673.1541514181-103582555.1541409738

It gives me "Repository not found" error. 

Do i need to subscribe to use the service or create new branch (like Github gh-pages) or what am i missing to show the page properly?

 

8 answers

1 accepted

1 vote
Answer accepted
Ana Retamal Atlassian Team Nov 08, 2018

Hi Sumartono!

Seems like you're not creating your repository with the right name, keep in mind the name of the repository has to be yourusername.bitbucket.io, where you should replace "yourusername" with the username associated to your Bitbucket account.  

I hope this clarifies things for you, let us know how it goes! And if you need any further help please don't hesitate to contact us again :) 

Best regards,

Ana

FireShot Capture 1 - Overview — Bitbucket - https___bitbucket.org_dashboard_overview.png

Hello Ana,

I did changed my repo name myonlinereview.bitbucket.io.

Still showing the same error message.

thanks

Ana Retamal Atlassian Team Nov 09, 2018

Hi! I've checked your Bitbucket account and I saw that 'myonlinereview' is not your username. To give you a hint I'll give you the first and last letter of your username: t******x.

Hope that helps!

Ana

thanks got it :)

Ana Retamal Atlassian Team Nov 13, 2018

Glad I could help! :D 

Hi @Ana Retamal ,

I've got the same issue.

My page is: sonnh84.bitbucket.io. I believe my username is sonnh84 too.

Could you help me check why it's not working please?

Thanks in advance!

Son NH

 

OK i got it, repository name should the complete slug, "xxxxx.bitbucket.io"

 

The article at https://confluence.atlassian.com/bitbucket/publishing-a-website-on-bitbucket-cloud-221449776.html does not make this clear at all. Not only does the link for "workspace ID" lead to a 404, but the entire article seems to imply that creating a repository named (as an example) mycoolproject.bitbucket.io would simply work.

In my case, I want to host a static site for one of my projects. I don't want to host it under pixelbath.bitbucket.io/mycoolproject, but there's no explanation of why we can't do that, and "Repository not found" is not a particularly helpful message.

Still no resolution. Seems like people would want to host a static site using bitbucket.

https://pages.bitbucket.io/

{username} needs to be your account username

Thanks. I get that is my username, but it still shows page not found. Which repo is this URL pulling from? 

if i remember correctly, the repos name has to be the same as your username. 

i.e account username: johndoe

repository name: johndoe

Ok. I guess I will try to rename my repo and relink stuff. It seems like Atlassian should have a simple online detailed explanation. 

Tyler T Atlassian Team May 11, 2020

Apologies for any confusion caused by the documentation.

If your workspace ID is johndoe, do the following:

  1. Create a repository with the slug: johndoe.bitbucket.io
  2. Upload an index.html file in the root
  3. Visit the URL: https://johndoe.bitbucket.io/
Like # people like this

Where the fuck in your shitty documentation does it say that the repository has to have the same name as the FQDN https://confluence.atlassian.com/bitbucket/publishing-a-website-on-bitbucket-cloud-221449776.html?_ga=2.36415269.420348087.1590408595-1004523555.1590408595

 

What a dumpster fire

Please follow "Tyler T " answer in this thread. It worked within seconds.
You can just fork your repo to this new 'accountname.bitbucket.io' repo so all files will be there. Heave a great day.

how to fix

Repository not found?


my link https://bitbucket.org/%7B09d54ef3-412f-4bb8-a012-7487ccad031a%7D/

please help me
Tyler T Atlassian Team May 11, 2020

Change the repository name to:

informasipinjamanonline.bitbucket.io

Like cyanos likes this

 

OK i got it, repository name should the complete slug, "xxxxx.bitbucket.io"

 

Like Tyler T likes this

Any resolution yet? 

me too help me my username is chaanchandan 

https://chaanchandan.bitbucket.io/

Repository not found

 

How did you get this working?

How can i write my name which have First and Last Name

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Git push size limits are coming to Bitbucket Cloud starting April 4th, 2022

Beginning on April 4th, we will be implementing push limits. This means that your push cannot be completed if it is over 3.5 GB. If you do attempt to complete a push that is over 3.5 GB, it will fail...

2,130 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you