Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,773
Community Members
 
Community Events
176
Community Groups

App pass in Jenkins doesn’t work

I am trying to change the authentication to app password for my account in Jenkins but still it throws a invalid credential error message if I use my app passw.

1 answer

0 votes

Hi @Ramesh Kumar and welcome to the community.

An app password should be used in combination with the Bitbucket username of the account for which you generated this app password. I am just mentioning this because I've seen some users have been using the label of the app password instead. The Bitbucket username can be found here https://bitbucket.org/account/settings/ if you are logged in to the account.

If that's ok, the next thing to look into would be the app password permissions, and the correct permissions depend on what Jenkins is doing with these credentials. If it is only cloning/pulling from repos, then Repositories:Read permissions for the app password should be enough. If additional operations are performed, more permissions may be required for the app password. It is not possible to change the permissions for an existing app password, but you can generate a new one.

Is there some log file in Jenkins where you can see what git commands or API calls are executed, and also if there are any additional error messages apart from "invalid credential"?

Kind regards,
Theodora

I can confirm.

Jenkins can now PULL, but it can no longer PUSH to repositories.  I have had several repositories automatically pushing to branches based on requirements.

Jenkins can no longer PUSH to those same repositories.  It will simply HANG.

The APPPassword I am using works to pull the code down, but it can no longer push the code up to Bitbucket.

I have given the AppPassword account full rights across the board.

I have tried to do this with command line (which worked before), moved over to powershell and even tried Shell commands.

Jenkins can no longer push with these new AppPasswords.

Hi Scott,

If you'd like us to help with your issue, please create a new question via https://community.atlassian.com/t5/forums/postpage/board-id/bitbucket-questions

It's best to have a separate question, as troubleshooting multiple users' issues in the same post can become confusing and make it difficult to follow the post.

You can copy-paste in the new question the content of your previous reply, and it would additionally be useful to include:

  • any logs from Jenkins with the exact commands that are executed and their full output (please mask/remove any actual usernames/repo names/workspace-id prior to sharing).
    Without knowing the commands and their output, it's difficult to guess why the operations are failing.
  • it would be useful to have the same (commands+output) when you execute the commands from a command-line application

Kind regards,
Theodora

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events