Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,772
Community Members
 
Community Events
176
Community Groups

After I set up "two-step verification", I still can't enable pipelines

When I tried to switch the button "Enable pipelines", it prompted me to "Two-step verification is required to enable pipelines". After I set up two-step verification, I log out and log in using two-step verification, the prompt is still there.

How to handle it? 

2 answers

1 accepted

1 vote
Answer accepted

Hi @David_Dong2023 and @Lucas Mbiwe,

Bitbucket uses Atlassian accounts (the ones for https://id.atlassian.com/) for authentication.

At the moment, it is possible to set up 2FA both for a Bitbucket account (from this page: https://bitbucket.org/account/settings/two-step-verification/manage) and also for the linked Atlassian account (from this page: https://id.atlassian.com/manage-profile/security).

In order to enable Pipelines, you need to enable 2FA for the Bitbucket account (instead of the Atlassian account).

It sounds like you may have enabled the Atlassian account 2FA, which is not taken into account when enabling Pipelines.

After you enable Bitbucket 2FA, you may want to disable Atlassian account 2FA, in order to avoid entering a 2FA code twice when logging in to Bitbucket.

Kind regards,
Theodora

Thank you for clarifying this, @Theodora Boudale. Makes perfect sense. 

You are very welcome Lucas, please feel free to reach out if you ever need anything else!

This worked for me, thanks

not working for me please help me asap im frustrated due to this

@David_Dong2023, I ran into the exact same problem. That's how I found your question.

When I double-checked my 2FA setup up in my account settings, it looked as if I hadn't set it up yet, although I had just logged in using a 2FA code from my authenticator app.

I then scanned the QR code with my authenticator app again. Interestingly, the first time I did it the app set the entry up as ‘Atlassian’ with my email address as user name, the second time it resulted in ‘Bitbucket’ with my Atlassian user name as the user name. I'm pretty sure I did the exact same thing as the first time, but obviously the result was a different one. 🤷🏽

The good news is after the second time setting up 2FA I was able to enable the pipelines in my project.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events