Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,464,828
Community Members
 
Community Events
176
Community Groups

Account and SSH when SSO with Google

Hi 

Some time ago I used SourceTree via SSO authentication with google and its HTTPS protocol.

Punctually after a few weeks or months the token expires and sometimes I can no longer access the repo.

So I tried to use SSH keys which are MUCH more stable, and work great when they work. In fact, the repo often remains inaccessible to me for a few hours and then starts working again.

I also tried to connect the computer via cell phone by removing all firewalls but nothing ... I think it's not my connection.

Is anyone else experiencing these disruptions?

2 answers

0 votes
Norbert C Atlassian Team Feb 28, 2022

Hi Albert,

Thank you for contacting Atlassian Community, my name is Norbert and I'm a Bitbucket Cloud Support Engineer, it's nice to meet with you!

I would like to inform you that we're not experiencing any issues with Bitbucket Cloud and personally when I use SourceTree it's working as expected for me.

  • Can you tell me whether if you're using the latest version of SourceTree?
  • Do you get any error message when you try to access repositories, but it fails?

Please let me know, we're here to help.

Best Regards,
Norbert
Atlassian Bitbucket Cloud Support

Hi Norbert,

This is the log of my commit with push.

git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks commit -q -F C:\Users\xxxxxx_xxxxxxxxx\AppData\Local\Temp\iq352h03.2sg

git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks push -v --tags --set-upstream origin 260-TU001:260-TU001
Pushing to bitbucket.org:xxxxx/xxxxxxxxxxxxxxxxx.git
Connection reset by 104.192.141.1 port 22
fatal: Could not read from remote repository.

This is my configuration of SourceTree 3.4.7 (windows) 

ST-Config.png

In the BitBucket user configuration, there are the keys (and it works fine many time a day)

bb-user-key.png

P.S. ... no it is not working, probably in a couple of hours it will work fine!

Now it works, a few minutes later, without changing any configuration.

OK-Push.png

Norbert C Atlassian Team Mar 02, 2022

Hi @albertuan 

This is sound interesting. Currently when your system is trying to connect to 104.192.141.1 IP, it's trying to connect to an AWS Global Accelerator IP: https://bitbucket.org/blog/speeding-up-bitbucket-cloud-with-aws-global-accelerator-and-adding-some-new-ip-ranges

I suspect your system might be having issues to connect to the AWS Global Accelerator service.

As a workaround, temporarily can you change your hosts file so that it points to the old original Bitbucket Cloud IP, which is not using the AWS service?

18.205.93.1 bitbucket.org

Please let me know if that helps.

I'm looking forward to hear from you, Albert.

Best Regards,
Norbert
Atlassian Bitbucket Cloud Support 

Hi Norbert,

thanks for your help. It will be precious if it will happen again. Indeed, in these first 14 days of March, we did not have any issue.

I'll keep update this thread if there will be any news.

Norbert C Atlassian Team Mar 14, 2022

Thanks @albertuan , please keep me informed how it goes.

Have a good day!

Best Regards,
Norbert
Atlassian Bitbucket Cloud Support

Hi,

 

I'm a colleague of @albertuan . The problem is happening again.

It was working fine since this morning and in the last 30 minute the error:

git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks fetch --no-tags origin
ssh: connect to host bitbucket.org port 22: Network is unreachable
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

We are reaching the repo in SSH with the public key stored in the BitBucket user. 
ssh-bitbucket.png

P.S. in the while we have write down the previous post, the System is working fine again.

:-/ 

Norbert C Atlassian Team Jul 13, 2022

Interesting, how long was this issue happening? A minute or two or for a long time?

For me it seems, that the network is blocking the access to Bitbucket Cloud. Can you ask your network admin and see if they can see any connection being blocked?

Also when this issue is happening, can you check whether if you can telnet to bitbucket? You can check this by using the following command:


telnet bitbucket.org 22

 Please let me know.

 

Best Regards,

Norbert

Atlassian Bitbucket Cloud Support

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events