Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,369,760
Community Members
 
Community Events
168
Community Groups

Can I use Elasticsearch 2.4 with Bitbucket Data Center 5.8?

I know Elasticsearch is required to run Bitbucket Data Center and that Support for Elasticsearch 2.3 ended with Bitbucket 5.7.

We have an internal Elasticsearch cluster that is still on v2.4 for a bunch of reasons. It's on the roadmap to upgrade, but it may be a while and we need to get Bitbucket Data Center in before that's likely to happen.

So, I thought about running Bitbucket Data Center 5.8 against our Elasticsearch 2.4 cluster until we get the cluster upgraded.

I know it's not supported, but does that mean it won't even work, or just that we're on our own until we upgrade our Elasticsearch cluster?

Has anyone else done this, or seen evidence that it will or won't work?

1 comment

Hi Craig,

Elasticsearch 2.4 was never supported with Bitbucket Server - support was limited to specific versions of 2.3. The reason is that the Buckler plugin that we provide to add authentication was built for these specific versions.

My understanding is that you can use any other version of Elasticsearch but the Buckler add-on will not work and therefore Elasticsearch will not be secured by authentication.

Note that we continue to support Elasticsearch 2.3 until Bitbucket 6.0 is released.

Cheers,

Christian

Premier Support Engineer

Atlassian

Thanks Christian, exactly the details I needed to know.

Cheers,

Craig.

Comment

Log in or Sign up to comment
TAGS

Atlassian Community Events