Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

rsync-deploy mismatched GLIBC version Edited

Hello,

I try to setup a deploy step in bitbucket piplines. Sadly I have problem with that.

That is how my pipeline look's atm:

name: Deploy Staging
deployment: staging
trigger: manual
script:
- pipe: atlassian/rsync-deploy:0.5.0
variables:
USER: $DEPLOY_USER
SERVER: $DEPLOY_SERVER
REMOTE_PATH: $DEPLOY_PATH
LOCAL_PATH: "${BITBUCKET_CLONE_DIR}/html"
EXTRA_ARGS: "--rsync-path=/usr/bin/rsync"

 At the end following errors will be displayed:

INFO: Executing the pipe...
...
...
/usr/bin/rsync: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.27' not found (required by /usr/lib/x86_64-linux-gnu/libpopt.so.0)

rsync: connection unexpectedly closed (0 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at io.c(226) [sender=3.1.3]
✖ Deployment failed.

On The server following Versions are installed:

    rsync --version
    rsync version 3.1.3 protocol version 31

    ldd --version
    ldd (Debian GLIBC 2.28-10) 2.28


I did not managed to update the GLIBC version on the pipeline.
And up/downgrade on the rsync server is not possible.

 

Any solutions?

1 answer

0 votes

@Alexander Schlegel we will try to reproduce this and fix soon.

However, we need some details for you.

Before did you manage to use older versions without fail?

The thing is we did not change any version and did not met such a problem before.

Regards, Galyna

@Alexander Schlegel I also should provide such details that we have

bash-4.4# ldd --version
musl libc (x86_64)
Version 1.1.20

1.1.20 version installed.

But I don't think that it should affect the working pipe. We will try to reproduce this in the meantime

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket Pipelines

Bitbucket Pipelines Runners is now in open beta

We are excited to announce the open beta program for self-hosted runners. Bitbucket Pipelines Runners is available to everyone. Please try it and let us know your feedback. If you have any issue...

2,738 views 55 18
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you