It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

rpc error when testing bitbucket pipeline with opsgenie

Hi all,

   I was trying to test the Bitbucket pipeline to send some notification to the OpsGenie using the API key to make sure my integration is working. I created a API key for the OpsGenie integration as mentioned(https://docs.opsgenie.com/docs/api-integration) and pass the same in the pipe as below. But when i ran the pipeline I got the below error. Can anyone help in this regard how to fix it?

rpc error: code = Unknown desc = failed to pull and unpack image "docker.io/library/python:3.5.1": failed to unpack image on snapshotter overlayfs: failed to extract layer sha256:f5decf3b205f716ea71eadf4359dbdb2383b509021d18ef717b9518171e6f0fb: failed to unmount /var/lib/containerd/tmpmounts/containerd-mount615279362: failed to unmount target /var/lib/containerd/tmpmounts/containerd-mount615279362: device or resource busy: unknown

https://bitbucket.org/atlassian/opsgenie-send-alert/src/master/

 

bitbucket-pipelines.yml

image:
name: python:3.5.1

setup: &setup
step:
name: Installation of Pre-req
script:
- apt-get update # required to install zip
- apt-get install -y zip # required for packaging up the application
- pip install boto3==1.3.0 # required for codedeploy_deploy.py

alert-test: &alert-test
step:
name: Testing Send Alert email through OpsGenie
script:
- pipe: "atlassian/opsgenie-send-alert:0.4.2"
variables:
DESCRIPTION: "An Opsgenie alert sent from Bitbucket Pipelines"
GENIE_KEY: "345cc6b1-ce3a-4ff7-b5d5-e8210c904d9b"
MESSAGE: "Hello, world!"
PRIORITY: P1
SOURCE: "Bitbucket Pipelines"

pipelines:
branches:
master:
- <<: *setup
- <<: *alert-test
qa-*:
- <<: *setup
- <<: *alert-test

1 answer

1 accepted

0 votes
Answer accepted

I've seen these popping up more than usual, recently.

 

Re-running normally works for me. It's an internal issue with the pipeline step itself

Thank you.  yes rerunning it worked. But it pops up after rerunning the pipe couple of times intermittently.

After this I am getting another issue:

1.  Even if I am passing GENIE_KEY(hardcoded value) the pipe is not accepting it and fails with below error even if I pass the GENIE_KEY :    'API-KEY'

 

c497cb76b295: Pull complete1dff4a5e6b7e: Pull complete1ec9a3138c57: Pull completeDigest: sha256:aeb7b5cb945574cc2332f73ef19950142a3f1352e8fada540d7cb4c883545f2aStatus: Downloaded newer image for bitbucketpipelines/opsgenie-send-alert:0.4.2/pipe.sh: line 23: GENIE_KEY: GENIE_KEY variable missing.

 

I also tried setting up a repository variable as GENIE_KEY in pipeline and pass the GENIE_KEY.

 

test: &test
step:
name: Testing Send Alert email through OpsGenie
script:
- pipe: "atlassian/opsgenie-send-alert:0.4.2"
variables:
GENIE_KEY: '$GENIE_KEY'
MESSAGE: 'Hello, world!'
DESCRIPTION: 'An OpsGenie Alert sent from Bitbucket Pipelines'
PRIORITY: P4
SOURCE: 'Bitbucket Pipelines'

Looks like the GENIE_KEY is not getting passed to the opsgenie-send-alert pipe. Can anyone please help me in this regard?

 

Regards

Jamie

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket Pipelines

What We Learned When We Researched Open Source Vulnerabilities in 7 Popular Coding Languages

...hey are a part of us, shaping how we interact with the world around us. The same holds true for programming languages when we think about how different kinds of vulnerabilities raise their heads in t...

1,053 views 0 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you