impossible to publish artifacts for,java.io.IOException:missing artifact

I am running a plan in Bamboo with correct source repository but getting below error in step [ivy:]

BUILD FAILED

Error- build_comman.xml:894 :impossible to publish artifacts java.io.IOException:missing artifact.

 

I checked modeule name and project name is same in ivy.xml and build.xml. The same plan was running fine few months back, but now throwing this error and failing.

1 answer

1 accepted

We found the root cause of this issue. There was and prefix  "prd" added in environmentprefix="prd" in <create_ear_macro .../> in build.xml.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,824 views 0 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you