Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,359,887
Community Members
 
Community Events
168
Community Groups

bamboo, remote agent authenticated but missing from agent summary list

I previously had 3 bamboo agents running on my linux "build" machine connecting to a bamboo server running on Windows. The directory for one of the build agents got corrupted and needed to be deleted. After downloading the installer jar and reinstalling the agent I went on the bamboo server and removed the old agent and authenticated the new agent. The agent is now visible on the authentication list as approved. From this point onward however, the new agent never shows up on the server's Agent Summary page. 

Going forward I installed a new remote agent on another linux system, followed the same steps and authenticated it on the bamboo server agent page. At this point the new agent shows up as a remote agent.

Ideas? Suggestions on what logs to look at?

thanks in advance for any help.

 

1 answer

Here's an interesting, and frustrating, data point. After initially starting the agent on 1/14 and authenticating shortly thereafter. Now on the agent summary page the agent is there and this line is in the log on that page:

Jan 20, 2021 10:25:55 AM Remote agent "mcsbuild03.xxxxxxx.com" has registered. 

SIx days??? What the ....?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 9.0 is now available

Hey there, Data Center community! I'm Martyna Wojtas and I am the Product Manager for Bamboo Data Center. I’m excited to share that Bamboo 9.0 is now available. We purpose-built this platform to help...

302 views 0 7
Read article

Atlassian Community Events