Why can't I select node.js version to be 0.11 and use harmony generators flag?

Only node version I see in Bamboo task configuration is 0.10. How do I get to 0.11?

1 answer

0 votes
Marcin Oles Atlassian Team Sep 23, 2015

Hi Bogdan,

the reason for that is that there are no Bamboo agents that know such capability within your Bamboo instance.

The capabilities that you can choose for Node.js plugin are those that are currently known to Bamboo build agents. If no build agent, and no elastic image, and neither the server knows "Node.js 0.11" as a capability, then you'll not be able to select it.

If you're using Bamboo Cloud, I'd recommend waiting a little, since I think more Node.js versions will be added to stock images soon (stock images are those provided by Bamboo, so no action is needed). You can also always create your own custom EC2 images with custom capabilities, including different version of Node.js. Here is some instruction on how to do this: https://confluence.atlassian.com/bamboo/creating-a-custom-elastic-image-289277146.html

Cheers,
Marcin

Suggest an answer

Log in or Join to answer
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,066 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot