SCP Task not working in Bamboo

Hi there,

I've got an SCP task set up to copy some files from the Bamboo build server to another server machine. I can connect to the destination server, using any type of SFTP program (WINSCP) and manually xfer a file, but when I do it via Bamboo in a plan, via the SCP Task, it doesn't xfer the file. It also does not give me any errors. The build completes successfully and the task starts and ends within a second or 2 of it starting, but no files are copied. I can't seem to find out why this is happening. Any ideas/help please?

8 answers

0 votes
Eddie Webb Community Champion Aug 07, 2013

Are you using the full path and not a ~ for the remote? are you sure the source dir has the file?

What method are you using for authentication?

Hi Eddie, Thanks for your response.

I'm using the full path in the local path section.

C:\inetpub\wwwroot\test.txt

and the file is there in the above directory.

Method for authentication is password. This is also correct otherwise it would have given me a connection error.

I have also tried C:\inetpub\wwwroot\*.txt - no difference

The remote path is:

/wwwroot/

But I have tried \wwwroot\ , \wwwroot/ , /wwwroot , \wwwroot , etc to no avail.

0 votes
Eddie Webb Community Champion Aug 14, 2013

What OS is the remote machine? What OS is the bamboo agent running on?

It is very unlikely that a windows (assuming IIS based on folder name) machine has root folder /wwwroot. It is likely this folder is under c:/Inetpub/wwwroot on both machines.

http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/a59a2665-9078-43ef-8b5a-5bf9bcacc95e.mspx?mfr=true

Both are Windows Server 2008 R2

The /wwwroot is the virtual name which is putting to the physical path of c:\inetpub\wwwroot on the remote machine.

Also, if I use a SFTP program, such as WinSCP, I can manually xfer the file to the /wwwroot folder (virtual name) with no issues. It's only via the bamboo SCP task that it does not copy across???

Thanks for your suggestions though.

Have you all found a solution for this. I am having the same problem

Hello Marcus,

What is your version of Bamboo? and what version of "Bamboo SCP and SSH Tasks" plugin are you using? (You can check this by navigating to Bamboo Administration - > Manage Add-ons - > Show System Add-ons).

If you are not running Bamboo 5.3 and it's possible for you to upgrade your Bamboo instance to the latest version, please upgrade and check if the problem persists.

https://confluence.atlassian.com/display/BAMBOO/Bamboo+generic+upgrade+guide

https://confluence.atlassian.com/display/BAMBOO/Bamboo+upgrade+guides

We experienced issues with the SCP task plugin in previous versions that are resolved now. If you continue to experience the same problem or if upgrade is not an option for you please open a support ticket at https://support.atlassian.com.

Thank you.

Best,

Sepideh

I am using the latest version of Bamboo already (5.3) and for the SCP plugin, i am using 5.0.8. http://prntscr.com/2n6nc7My build runs as successfully but no files are transfering http://prntscr.com/2n6zis

I do have my instance of Bamboo on a Windows server and I am deploying to my linux server. but that should be a problem

Hi Marcus,

In that case we need to look at the log files. Please open a Bamboo support ticket at https://support.atlassian.comand attach your bamboo logs from under <bamboo-home>/logs.

Thank you.

Best,

Sepideh

Has this been fixed in the meantime? I am Experiencing the same problem. Our Bamboo Version is 5.10.3. 

Suggest an answer

Log in or Join to answer
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,066 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot