How do I configure Bamboo to correctly show the build reason?

I have Bitbucket set up to send hooks to Bamboo, and Bamboo set to trigger builds when receiving hooks.  Functionally, it works fine.  However the build reason that Bamboo shows is always "Manual run by (Admin)".  How can I get Bamboo to show that it was triggered by code changes from (Developer)?

I also have some scheduled builds, and these work fine but show "Manual run by (Admin)" rather than an appropriate message.

1 answer

0 vote

I think this had been caused by the following issue with the Bamboo <=> Bitbucket integration which has since been resolved:

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,815 views 0 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you