Delete a plan in the queue via REST api doesn't work?

Hi guys,

I tried to delete a plan in the queue of our bamboo server via rest api like stated in the documentation: https://developer.atlassian.com/static/rest/bamboo/4.0.html#idp310752

I have the following REST statement

curl -X DELETE -u "user:password" rest/api/latest/queue/PROJ-PLAN-JOB1-78

But I always get 

HTTP Status 405 - Method Not Allowed

as an error.
Other REST callls, for example about what is in the queue are working. 

I found an old ticket with the exact same error from 2013: https://jira.atlassian.com/browse/BAM-13948

 

 

So is this still not fixed beside the issue says it's resolved? Or is there any workaround for this?

1 answer

0 vote

It's resolved as duplicate of https://jira.atlassian.com/browse/BAM-13990 which is still open

Suggest an answer

Log in or Join to answer
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,096 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot