Build expiry is not working correctly for artifacts

 

Expiry logic we have defined: anything older than 14 days can be removed, unless it is tagged “final” or “saveme”, with a minimum of 2 assets saved. 

I have checked that some branches (e.g. OPL3-SBE8) are correctly deleting assets for builds older than 14 days, but it looks like OPL3-SBE3 and 4 are not working correctly.

 

2 answers

This widget could not be displayed.

Hello Bharath,

It looks like support request which requires more investigation. Can you please create an issue at support.atlassian.com?

This widget could not be displayed.

Hi @Bharath,

It is not clear which Bamboo version you are running, but please keep in mind that Deployment release artifact expiry was added to Bamboo 5.7. Before that, only regular build artifacts could be deleted.

Can you please check if these artifacts that are not being deleted are really from regular builds, and not from deployments?

Kind regards,
Felipe Kraemer

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

204 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you