Bamboo triggers deployment without trigger set in the deployment plan?

I am using Bamboo 5.6.2.

The steps I followed,

  1. Setup trigger in deployment plan to start the deployment once the release build plan is success
  2. Did a release and the released package was deployed by the deployment plan.
  3. Removed the trigger in deployment plan to disable the auto deployment
  4. Did a release build and still the deployment plan triggered automatically once the build was success, which is strange.

 

2 answers

That sounds frustrating. Try restarting Bamboo which may surprisingly fix it.

Make sure you saved your change (removing the trigger).  Recently Atlassian changed the way bamboo "saves" things.  (specifically variables) and I often find myself disabling things, and then forgetting to scroll to the bottom of the page to save the changes.  Surprise, it didn't change if it didn't get saved...(grumbles...)  This may not be what you're experiencing but it may be worth checking.

Suggest an answer

Log in or Sign up to answer
Community showcase
Asked Dec 06, 2018 in Jira Ops

I'm John Allspaw, Ask Me Anything about incident analysis and postmortems

I'm John Allspaw, co-founder of   Adaptive Capacity Labs, where we help teams use their incidents to learn and improve. We bring research-driven methods and approaches to drive effective inciden...

5,540 views 21 17
View question

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you