Bamboo triggers deployment without trigger set in the deployment plan?

I am using Bamboo 5.6.2.

The steps I followed,

  1. Setup trigger in deployment plan to start the deployment once the release build plan is success
  2. Did a release and the released package was deployed by the deployment plan.
  3. Removed the trigger in deployment plan to disable the auto deployment
  4. Did a release build and still the deployment plan triggered automatically once the build was success, which is strange.

 

2 answers

This widget could not be displayed.

That sounds frustrating. Try restarting Bamboo which may surprisingly fix it.

This widget could not be displayed.

Make sure you saved your change (removing the trigger).  Recently Atlassian changed the way bamboo "saves" things.  (specifically variables) and I often find myself disabling things, and then forgetting to scroll to the bottom of the page to save the changes.  Surprise, it didn't change if it didn't get saved...(grumbles...)  This may not be what you're experiencing but it may be worth checking.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

217 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you