Bamboo integration with old Bitbucket

NPapanicolaou March 3, 2023

Hello!

We want to upgrade our Bamboo Server to Bamboo DC.

Of course we wanted to have latest version (9.2) but it seems the integration with our version Bitbucket Server cannot work as our Bitbucket is too old (5.14)

We have planned to upgrade Bitbucket in a near future, so for now we thought that we could upgrade Bamboo to 8.2 because it seems to not mention that it will still work with our current version of Bitbucket.

I couldn't find a clear Atlassian application matrix compatibilities with Bamboo DC 8.2.

Can someone confirm that Bamboo DC 8.2 is compatible with Bitbucket 5.14?

Thank you

1 answer

1 accepted

2 votes
Answer accepted
Eduardo Alvarenga
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
March 4, 2023

Hello @NPapanicolaou

Bitbucket 5.14 had its end-of-support date on 11 Sept 2020. Bamboo 7.1.2 was released on 01 Sept 2020 meaning that was the last release of Bamboo that had official compatibility with Bitbucket 5.14.

There is no way to guarantee any compatibility between both versions as we do not test release integration between product versions that had reached their end of life. It is very likely that Bitbucket 5.14 will work up to the latest Bamboo 8.2.x release. On the other hand, Bamboo 9.0.1 officially states Bitbucket earlier than 7.5 will not be supported.

We recommend you try that integration but at the same time have a backup plan to upgrade Bitbucket as an alternative solution.

Thank you,

Eduardo Alvarenga
Atlassian Support APAC

--please don't forget to Accept the answer if the reply is helpful-- 

NPapanicolaou March 6, 2023

Alright. Thank you for your answer.

NPapanicolaou March 6, 2023

Hello @Eduardo Alvarenga 

Another question on this, even if we upgrade the Bitbucket Server version to the latest, the bamboo integration would still work if I'm not mistaken..

I have seen this page : https://confluence.atlassian.com/bitbucketserver/supported-platforms-776640981.html

If this isn't the case, I would need to upgrade both at the same time?

Thank you

Eduardo Alvarenga
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
March 6, 2023

Hello @NPapanicolaou,

Recent Bitbucket releases require at least Bamboo 5.6 or 7.0 an later to support it as an integrated CI/CD. So yes, you will have to upgrade both products.

Eduardo Alvarenga
Atlassian Support APAC

--please don't forget to Accept the answer if the reply is helpful-- 

Like # people like this
NPapanicolaou March 6, 2023

Thank you again for the answer @Eduardo Alvarenga .

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events