Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Bamboo Installation: Does it have to be localhost?

I am installing Bamboo on a test server under an evaluation license. The server starts up with bin/, but it can't be reached by browser. I'm trying to track down the cause of the problem.

The installation document says that after you run for the first time you should look at localhost:8085. Since this is a remote machine I can't run a local browser and am trying to connect through the machine's name. Can the initial connection come from a remote machine, or does it have to be the same one bamboo is installed on?

lsof -i shows that bamboo's tomcat instance is listening on port 8085

7 answers

Hey Todd

use a netstat to see what IP address you bamboo process is connected to : (*nix) netstat -an| grep 8085

if it is 0's,  or - you can either update your etc hosts by adding the hostname to the /ect/host file (or)

edit <install-dor/conf/server.xml  add this to the 8085  connector


address="123.456.789.11"   where 123.456.789.11  is your host IP address in double quotes.

restart and try.

good luck!

Hey @James Saxton

I have tried the 2nd method that you had mentioned, but it is not working. Please refer to this issue and these comments. You will have a better understanding. Do you have any resolution idea because I have tried opening the ports, still i'm getting bricked. 



Nic Brough -Adaptavist-
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Aug 02, 2018

This is an old post, and an answered one.  You're very unlikely to get any help here.

use jenkins

Turns out our new systems automation software has a firewall module that isn't iptables.

Wiping egg off my face

change "remove" to "remote" is note above

if you can connect - try to telnet from a remote *nix machine to the bamboo server using the above command




looks like you are running *nix

the telnet to localhost 8085 will return a connection refused, bamboo is bound to the ip address of 5not

on the server running bamboo try this

telnet 8085


if you get a connection refused - the port is blocked by iptables (most likely)

if you can connect - try to telnet from a remove *nix machine to the bamboo server using the above command

if you get a connection refused - firewall or iptables again may be blocking you.

I'll look for your response.  The bamboo process is running so that is great!


The bamboo process is running so that is great


0 votes
Daniel Wester
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Feb 23, 2015

Do you have a firewall or similar on the server?

still no love. Will have to 

netstat -an | grep 8085
tcp 0 0* LISTEN

and a telnet to localhost 8085 gives connection refused

ps -ef | grep bamb
tomcat 15206 1 6 13:07 pts/0 00:00:35 /usr/bin/java -Djava.util.logging.config.file=/opt/atlassian/atlassian-bamboo-5.6.0/conf/ -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -XX:MaxPermSize=256m -Xms256m -Xmx384m -Djava.endorsed.dirs=/opt/atlassian/atlassian-bamboo-5.6.0/endorsed -classpath /opt/atlassian/atlassian-bamboo-5.6.0/bin/bootstrap.jar:/opt/atlassian/atlassian-bamboo-5.6.0/bin/tomcat-juli.jar -Dcatalina.base=/opt/atlassian/atlassian-bamboo-5.6.0 -Dcatalina.home=/opt/atlassian/atlassian-bamboo-5.6.0 org.apache.catalina.startup.Bootstrap start


Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events