Changing the server listening ip address

I'm a beginner to bamboo tool.

I have installed bamboo 6.2.3 on centos 7.

I don't know how to change localhost ip address.

Can anyone help me on this?

1 answer

1 accepted

0 votes
Accepted answer
Gonchik Tsymzhitov Community Champion Nov 29, 2017

Hello Jothi, 

 

could you clarify you question? 

What do you mean change localhost ip? 

1. If you mean how to change ip address on CentOS, you need follow this docs

http://www.itzgeek.com/how-tos/linux/centos-how-tos/how-to-configure-static-ip-address-in-centos-7-rhel-7-fedora-26.html

 

Regarding localhost is 127.0.0.1 or ::1, anyway it is loopback address. It is bad path for change it.

 

2. If you mean how to change binding address for bamboo, you can do it using .

You need use below instruction:

https://community.atlassian.com/t5/Bamboo-questions/Bind-bamboo-to-specific-interface/qaq-p/424423 

 

3. If you can not connect to bamboo server using like one of 80, 8080, 443, 8443 and broker ports. 

Let's check you firewall and SELinux. (I am using Oracle Linux 7, it is so often is firewalld, selinux components) e.g.


systemctl status firewalld

systemctl stop firewalld

systemctl disable firewalld

 

Hope it helps.

 

 

Cheers,

Gonchik Tsymzhitov

Thanks Gonchik Tsymzhitov.

I need to change binding address of bamboo instead of http://localhost:8085/ to my machine IP

 

Gonchik Tsymzhitov Community Champion Nov 30, 2017

Hm, it should bind from your ip address,  

kindly could you provide connector config? Located here

<Bamboo home directory>/conf/server.xml file.

 

Could you provide result after this command: 

telnet bamboo_ip_address 8085

Hi ,

This is my server.xml

<?xml version="1.0" encoding="utf-8"?>
<!--
   ====================================================================================

   Atlassian Bamboo Server Edition Tomcat Configuration.


   See the following for more information

   https://confluence.atlassian.com/display/BAMBOO/Installing+and+upgrading+Bamboo

   ====================================================================================
 -->
<!--
  Licensed to the Apache Software Foundation (ASF) under one or more
  contributor license agreements.  See the NOTICE file distributed with
  this work for additional information regarding copyright ownership.
  The ASF licenses this file to You under the Apache License, Version 2.0
  (the "License"); you may not use this file except in compliance with
  the License.  You may obtain a copy of the License at

      http://www.apache.org/licenses/LICENSE-2.0

  Unless required by applicable law or agreed to in writing, software
  distributed under the License is distributed on an "AS IS" BASIS,
  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
  See the License for the specific language governing permissions and
  limitations under the License.
-->
<Server port="8007" shutdown="SHUTDOWN">

    <!--APR library loader. Documentation at /docs/apr.html -->
    <Listener className="org.apache.catalina.core.AprLifecycleListener" SSLEngine="on"/>
    <!-- JMX Support for the Tomcat server. Documentation at /docs/non-existent.html -->
    <Listener className="org.apache.catalina.mbeans.GlobalResourcesLifecycleListener"/>

    <!-- Global JNDI resources
         Documentation at /docs/jndi-resources-howto.html
    -->

    <!-- A "Service" is a collection of one or more "Connectors" that share
        a single "Container" Note:  A "Service" is not itself a "Container",
        so you may not define subcomponents such as "Valves" at this level.
        Documentation at /docs/config/service.html
    -->
    <Service name="Catalina">

        <Connector
            protocol="HTTP/1.1"
            port="8085"

            maxThreads="150" minSpareThreads="25"
            connectionTimeout="20000"
            disableUploadTimeout="true"
            acceptCount="100"

            enableLookups="false"
            maxHttpHeaderSize="8192"

            useBodyEncodingForURI="true"
            URIEncoding="UTF-8"

            redirectPort="8443"
            />

        <!--
        ====================================================================================
        To run Bamboo via HTTPS:
             * Uncomment the Connector below
             * Execute:
                 %JAVA_HOME%\bin\keytool -genkey -alias tomcat -keyalg RSA (Windows)
                 $JAVA_HOME/bin/keytool -genkey -alias tomcat -keyalg RSA  (Unix)
               with a password value of "changeit" for both the certificate and the keystore itself.
             * Restart and visit https://localhost:8443/

             For more info, see :
              https://confluence.atlassian.com/display/BAMBOO/Securing+Bamboo+with+Tomcat+using+SSL
              and
              http://tomcat.apache.org/tomcat-8.0-doc/ssl-howto.html
        ====================================================================================
        -->

        <!--
        <Connector
            port="8443"

            maxThreads="150" minSpareThreads="25"
            connectionTimeout="20000"
            disableUploadTimeout="true"
            acceptCount="100"

            enableLookups="false"
            maxHttpHeaderSize="8192"

            useBodyEncodingForURI="true"
            URIEncoding="UTF-8"

            scheme="https" secure="true" SSLEnabled="true" sslProtocol="TLS"
            clientAuth="false"
        />
        -->
        <!--
         ====================================================================================
         
         If you have Apache AJP Connector (mod_ajp) as a proxy in front of Bamboo you should uncomment the following connector configuration line

         See the following for more information :

            https://confluence.atlassian.com/display/BAMBOO/Securing+Bamboo+with+Apache+using+SSL

         ====================================================================================
        -->

        <!--
              <Connector port="8009" redirectPort="8443" enableLookups="false" protocol="AJP/1.3" URIEncoding="UTF-8"/>
        -->

        <Engine name="Catalina" defaultHost="localhost">
            <Host name="localhost" appBase="webapps" unpackWARs="true" autoDeploy="true">

                <Context path="" docBase="${catalina.home}/atlassian-bamboo" reloadable="false" useHttpOnly="true">

                    <!--<Resource name="UserTransaction" auth="Container" type="javax.transaction.UserTransaction"-->
                              <!--factory="org.objectweb.jotm.UserTransactionFactory" jotm.timeout="60"/>-->
                    <Manager pathname=""/>
                </Context>

            </Host>

            <Valve className="org.apache.catalina.valves.AccessLogValve" resolveHosts="false"
                   pattern="%a %t &quot;%m %U%q %H&quot; %s %b %D &quot;%{Referer}i&quot; &quot;%{User-Agent}i&quot;"/>

            <!-- StuckThreadDetectionValve added below to print stack traces if a thread has been stuck for 60 seconds -->
            <Valve className="org.apache.catalina.valves.StuckThreadDetectionValve" threshold="60" />
        </Engine>
    </Service>
</Server>

Gonchik Tsymzhitov Community Champion Nov 30, 2017

Could you provide result after this command: 

telnet bamboo_ip_address 8085

 

???

Yeah I sent result after that only

@Gonchik TsymzhitovI have tried it, but it is not working. I have changed localhost to static-ip, but bamboo is not starting up. Also please refer to this issue.

You can't change localhost (well, you can, but that way lies madness).  Localhost should always point to 127.0.0.1 and/or ::1

You need to look at the external ip address of your Bamboo machine, the one that connects it to your network.  Try ip or ipconfig to find out what it is.

What happens if you

telnet <external address> 8085 ?

Hi @Nic Brough [Adaptavist].

Please find my response.

adi@sw:$ telnet 192.1xx.xx.xx 8085

Trying 192.1xx.xx.xx...

Unable to connect to remote host: connection refused

I have enabled port 8085 via ufw, yet telnet is still showing the aforementioned error.

adi@sw: $ ps -ef | grep bamboo

adi 2677 2404 0 06:40 pts/0 00.00.00 grep --color=auto bamboo

PS: My OS is Ubuntu 18.04 & there are no firewall rules because it is a personal network.

Regards

Aditya

If you're "enabling port 8085 via ufw", then there is a firewall, irrespective of your network type.

Connection refused means that the ip:port is blocked by a firewall, or nothing is running there.

@Nic Brough [Adaptavist]

Thanks for the quick reply.

When I mentioned personal network I meant no corporate firewall kind of restrictions. What do I do here? How I unblock it so that I can access bamboo?

I want bamboo's static IP to be properly linked with bitbucket's container IP.

PS: I have updated my earlier comment

This does not change my response, you have a firewall if you are using ufw, and that is blocking it, or, Bamboo is not running, or your network is not routing the request to the bamboo server

Suggest an answer

Log in or Sign up to answer
Community showcase
Asked Thursday in Jira Ops

I'm John Allspaw, Ask Me Anything about incident analysis and postmortems

I'm John Allspaw, co-founder of   Adaptive Capacity Labs, where we help teams use their incidents to learn and improve. We bring research-driven methods and approaches to drive effective inciden...

441 views 2 5
View question

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you