Bamboo 5.10 jdk 8 requirement question

The release notes for bamboo 5.10 state that jdk 1.8 is now required for the server and compile. I am looking for a clarification on the compile aspect. Does that mean that the agents must run on jdk 1.8 and that it can only run java builds using the jdk 1.8 compiler or does that mean the agent has to be running on jdk 1.8 but you can still define a build capability for jdk 1.7 and use that to do your build? We have come to both conclusions when read by multiple people at my company and I am hoping I can get a definitive answer here.

1 answer

1 accepted

3 votes

You have to run the agent and the server using JDK 8 and you have to compile Bamboo source code using JDK 8.

You can use whichever JDK you need to build your builds.

Thank you Przemek for that clarification.  I had the same question.

Suggest an answer

Log in or Join to answer
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,096 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot