Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Webhook URL Error for Send Microsoft Teams Message action webhookb2

Hello,

I cannot enable the Send MS Teams Message action because Automation tells me the webhook URL is not OK.

The webhook URL looks like this https://COMPANY.webhook.office.com/webhookb2/XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXXXXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX/IncomingWebhook/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX

Automation gives me a warning sign /!\ and "Please enter a valid webhook URL like https://outlook.office.com/webhook/XXXXYYYY..."

Thanks a lot!

8 answers

After upgrading to Automation for Jira 7.2.6, you need to following the documentation at https://confluence.atlassian.com/automation/setting-configuration-properties-1026539532.html to set the ms.teams.notification.action.url.prefix property to the correct prefix.

If you don't set the prefix, it will default to https://outlook.office.com/webhook/

If you need both the old and new prefix, set the prefix to https:// so that it matches any secure URL.

Worked perfectly for me after updating Automation for Jira to 7.2.6! Thanks for pointing out the instructions Gareth, much appreciated!

Like Gareth Cantrell likes this

Worked for us as well. Thanks for pointing us in the right direction Gareth.

Like Gareth Cantrell likes this

Microsoft is apparently changing the format of all newly created Webhook URLs after 11/Jan, and the older "outlook.office.com/webhook" will be deprecated in 3 months

If you have access to the Microsoft365 Message Center, you can view the announcement here: https://admin.microsoft.com/AdminPortal/home?ref=MessageCenter&id=MC234048

I'd suggest raising a support request with Atlassian to address this.

Hi both,

Thanks for replying.

So this is a known bug:
[AUT-2103] Microsoft Teams webhooks are limited to specific URL

What's really frustrating is that it looks like this "URL verification" thing is a feature...
If so, please Atlassian and partners, keep it simple, please 🙏.

Cheers,
JG

Hello All,

Since Microsoft url has changed over time, we have removed the validation from Automation side in cloud. The new URL should be working now. Please let me know in case of issues. Apologies for the inconvenience.

Cheers
Sherry

hello @Sherry Goyal  

We are seeing this issue on Jira datacenter + automation 7.1.17

Do you know by any chance in which version of Automation this has been corrected?

thanks

Sherry Goyal Atlassian Team Feb 01, 2021

Hello @robert Mugabuhamye

We fixed it in cloud. Sorry I am not aware of the server.

@robert Mugabuhamye I see there was a new version for server that was released on 28/Jan that appears to address the MS Teams issues (version 7.2.6)

Thank you @Gareth Cantrell , I'm going to try that version

0 votes

Hi there,

we run into the same issue. Even with the bugfix update it won't work with the web-hook in our Jira. (Server 8.13.1 & Automation 7.2.6).

I tried to find out if I need to change something in the setup, but didn't succeed. I still get the "lease enter a valid webhook URL like https://outlook.office.com/webhook/XXXXYYYY..." Error Message. 

Did anyone find a solution for this?

Thanks,

Leonie

Hello @Leonie Breitmoser

II'm still experiencing the issue on the 7.2.6 version too 😔.

No solutions so far 

@robert Mugabuhamye 7.2.6 does indeed contain a solution for this issue, however it requires you make some configuration changes post installation.

It is not immediately obvious, until you read the release notes in conjunction with the documentation on setting configuration properties (see my answer above).

Hi all!

I tried the work-around in this article Setting configuration properties | Automation for Jira Data Center and Server 7.2 | Atlassian Documentation but had no luck. It turned out that since I run Jira on WINDOWS-machine then I was not able to use the CURL-command. After some talks with the Atlassian support they helped me with this Power-shell query and then I got it working:

$user = 'YOUR_USER_ADMIN'
$pass = 'PASSWORD'
$pair = "$($user):$($pass)"
$encodedCreds = [System.Convert]::ToBase64String([System.Text.Encoding]::ASCII.GetBytes($pair))
$basicAuthValue = "Basic $encodedCreds"
$Headers = @{
Authorization = $basicAuthValue
}
$Uri = 'https://<jira-base-url>/rest/cb-automation/1/configuration/property/bulk'
$Form = @{
"ms.teams.notification.action.url.prefix"="https://"
}
Invoke-WebRequest -Uri $Uri -Method Put -Body ($Form|ConvertTo-Json) -ContentType "application/json" -Headers $Headers

Change User and Password in the script and also to your Base-url and this will work. This will allow all webhooks that starts with https://.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Automation

Announcing the Jira automation template library!

Hi all,  After many months of work, I am delighted to announce the launch of the Jira Automation Template Library!  The Template Library is a new website dedicated to all things Jira au...

766 views 17 21
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you