Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,462,134
Community Members
 
Community Events
176
Community Groups

Teams does not show the lookupIssues result in the message

I had an automation which was working fine until some days ago, did not change anything about the automation itself, but somehow the lookupIssues result shows up empty in my teams channel message.

the lookup query (JQL) gives a result of 30 items

then the automation step sends it to teams, I do get the message in teams, but without the result list, just the first text part. 

step: send Microsoft teams message:

Hey team - we've got the following issues left in this sprint:
{{#lookupIssues}}
* {{key}}
{{/}}

 

What am i doing wrong here? :)

 

1 answer

0 votes

Hi @Tanja van Wijk 

Welcome to the Community!

It's hard to know what the issue might be without seeing the Automation rule, can you share it? and have you looked at the Audit log for the rule to see if there are any errors?

Thanks!

This is what i am trying to do:

automation.png

according to the Audit log, the JQL gave a result (also verified in the automation itself)

audit log.png

but teams shows this:

teams result.png

I'm having almost the same problem.  However, I receive as many updates in Teams as there are found items (in this case 4).   


I tested using the Send email action and I'm receiving 4 emails, but the email does contain the information I entered in the Content box:

{{#lookupIssues}}
* {{key}}: {{summary}} - {{assignee.displayName}}
{{/}}

Ok I played in the sand a bit.

@Tanja van WijkI was able to recreate your rule and test it, the full functionality worked for me. Even though it shows you the lookup results you might want to add a log action for {{lookupIssues}} to make sure the lookup is being fed into the smart value. Outside of that, since the message is being sent I wouldn't think it's an issue with the webhook but maybe try recreating the webhook in teams or make a second one to test with?

@Bill LeonardI think your issue might be due to the Subject, are you including a smart value in the Message title or email subject?

Hi @Luis Machado

I recreated the connector like you suggested above and that worked for the Teams update.  That's all I was really concerned with.  Thanks.

Like Luis Machado likes this

This is interesting.  It's now gone back to not including the issues.   I was adding information about the ticket (summary, assignee) and it stopped working. 

Message*
Please update the tickets below with a Project Update:

{{#lookupIssues}}
* {{key}}
{{/}}

 

Capture.JPG

That is interesting, I'm not sure what else to suggest at this point. It almost sounds like there's something happening in transit that is scrubbing the message.

Another interesting tidbit.  The Teams channel now shows the issues that were found.  Below is the same screenshot from above but with the issues that were found. Something must have changed.

 

teams.png

I indeed have the same, some really strange behavior which i cannot pinpoint to anything setup related. 

Have been playing around a bit and the below message structure now seems to work for me. Looks like the * was causing some issues in teams.

message.png

@Tanja van Wijk  - the * was creating a bullet list for me.  When I removed the * there were no line breaks. I'm doing something similar to what you have above now.  

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events