Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,297,387
Community Members
 
Community Events
165
Community Groups

No longer able to insert an "issue fields condition" within an "if/else block"

I have several automations which include an "issue fields condition" inserted within an "if/else block".

Below is an example:

Example.png

For whatever reason, the editor doesn't allow me add another component (effectively a 2nd "Issue field condition") where the Black Arrow is (above).

I tried to recreate the same automation from scratch.  And it wouldn't allow me to include a single Compare operation following the Lookup operation.  The only options were: Advanced Branching and Branch rule / related issues.

Anyone else running into this problem?  It significantly limits the range of things I can do.  Yes, I realize there are workarounds for this specific use case.  But my automations are quite involved.

Is this a bug that was introduced?  Or, was this purposely implemented to restrict these use cases?

Thanks,

Doug

2 answers

1 accepted

0 votes
Answer accepted

Hi there,

Apologies but this is indeed a bug: https://codebarrel.atlassian.net/browse/AUT-2350

We'll let you know once a fix is available. For now the work-around is to drag a condition onto the if branch as mentioned above.

Cheers,
Andreas

Hi @Andreas Knecht 

Thanks for your reply.

As a note, https://codebarrel.atlassian.net/browse/AUT-2350 (and the related https://jira.atlassian.com/browse/JSWCLOUD-22414) were created back in Jan, 2022.

But, I was able to create my rule (see code snippet above) on May 31, 2022.  At that time, the rule editor allowed me to add a condition (actually multiple) inside an IF Branch.  But now it doesn't.

Thankfully, there is that work-around. 

Thanks,

Doug

Hi @Doug Levitt 

I recall another post about this months ago, and the person noted they could do this by creating the condition outside of the if/else and then dragging it inside with the rule editor.  I just tried this and it still works...However...

As the rule editor does not offer adding the condition this way natively, I would test fully to ensure it works as you expect.  If it does, Perhaps log a defect to Atlassian for the editor problem/limitation.

Kind regards,
Bill

Thanks @Bill Sheboy for the head's up.  I will log a defect with Atlassian.  This previously worked.  So, it sounds like it's just a bug they recently introduced.

Doug

Like Bill Sheboy likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Atlassian Automation

Jira Automation: Sum Up Story Points Roundup (Initiatives -> Epics -> Story/Tasks -> Subtasks)

Hi Everyone, In this roundup we combine all the jira automation rules to sum up story points across different issue types. We start from the lowest level, summing up story points from sub-tasks t...

1,833 views 2 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you