Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,461,953
Community Members
 
Community Events
176
Community Groups

Copying number field using automation truncates the values.

I have use case where user enters a number field in Customfield A, and need to generate URL in second field e.g.: www.example.com/cusomfield.A

the issue is, if value in A is larger. e.g: 99898099 

then URL becomes: www.example.com/9.9898099E7

so my requirement is

  1. I need to remove decimal from the number field
  2. Need to get exactly same value as in Field A. no truncation etc.

 

it would be great if any one can help me with this.

Thanks 

2 answers

1 vote

Hi @Kautilya Fadia IN ,

You may change the number format in the smart value like this:

{{issue.Customfield A.format("###")}}

More info in the docs.

Hope it helps.

Regards

hi @Ignacio Pulgar 

I tried .format in automation but for some reason its not working. everytime I use .format it seems to ignore value in number field

2021-08-23 12_26_40-Clipboard.png

Attached snapshot of how I've configured it. 

Hi @Kautilya Fadia IN ,

When and how exactly does that format fail?

If format doesn't have a consistent behaviour, then I'd consider using a custom field of type Text (single line) instead of Number type.

Regards

Hi @Ignacio Pulgar 

the issue is, if value in A is larger. e.g: 99898099 

instead of getting example.com/99898099  

it puts example.com/

completely ignores customfield. although automation rule passes so no failure log. 

Hi @Kautilya Fadia IN ,

The format has worked for me in tests with higher numbers.

Maybe you can use a Text field (single line) to avoid number format issues.

Regards

yeah using text field was last option. This is pure numbers field. not sure why Jira behaves erratically with numbers. 

thanks for the help will try to use Text field.

Like Ignacio Pulgar likes this
0 votes
Simmo Atlassian Team Aug 22, 2021

Hi @Kautilya Fadia IN ,

If you could attach some screenshots of how you're generating the URL in the automation rule that would really help.

Cheers,

Simeon.

2021-08-23 12_26_40-Clipboard.png

I've customfield_11305 as Number field, which by default takes floating numbers. 

part with http://example.com is static, I just need to place customfield_11305 after URL like: if customfield_11305 = 11223322 URL should be: http://example.com/11223322

Simmo Atlassian Team Aug 23, 2021

@Kautilya Fadia IN , try changing the ### to a single #

That seemed to work for me

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events