Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,673
Community Members
 
Community Events
176
Community Groups

Migration fails using JCMA due to Cascading Custom Field with different Context

We were attempting a migration of 4 Jira Projects from Jira Server to Cloud to our sand-box environment using JCMA.  The migration was failing on JCMA on one of the Jira Projects due to there being a different context set for that project on a cascading custom field. The 3 Jira Projects migrated successfully and only the one project with the different context set had failed.

Is anyone aware of there being any limitations on JCMA regarding different contexts set for custom fields and what is the workaround for a successful migration?

JCMA V1.6.8

Example of Error Message: "customfield_10207: Specify a valid option 'id' for Risk Category. This caused 3 other items to fail."

1 answer

Hi @Kasturee 

I doubt if it was the field context which caused it..

Do you see any disabled option with the option name such as 'XYZ'  for the 'Risk Category' field ??

 

You should see the option name in the beginning of your error log.

"[XYZ] customfield_10207: Specify a valid option 'id' for Risk Category. This caused 3 other items to fail."

 

While I am not sure about the recommended solution, I feel we should temporarily enable the disabled options before migration.. Probably a limitation of JCMA.

Hi Majo. I checked the error logs and there is no option name/id in the error message

It might be a different error from what I have faced..

 

Atlassian should be able to help you via a Support ticket

Rob Horan Community Leader May 24, 2022

@Kasturee how was this resolved? What was the root cause?

Hi Rob. I tested migrating a different Jira Project with a different context set on a custom field and that worked perfectly. Also had disabled options on the custom field and it still worked. So, the issue was not context or disabled options related. Unfortunately, I do not know why that particular custom field with a different context caused an error.

We are going to do a full migration on our sandbox environment soon so want to see if error re-occurs and what other issues pop-up.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events