Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,467,306
Community Members
 
Community Events
177
Community Groups

gsuite integration does not give access to confluence

Hi there,

My org uses gsuite integration to manage users.

"All users from G Suite" is added in the settings/"product access" page to both products: Jira Software and Confluence.

Problem: New users do not get access to confluence. (But they do get access to Jira software.)

I tried to disable and re-enable gsuite linking, but had no success.

 

I can fix the issue on a per-user basis by adding new users manually to the "confluence-users" group, but that's causing extra work for every new user.

Can you please let me know how to fix gsuite integration?

1 answer

0 votes

Hello @Mirko Schmidt,

Welcome to Atlassian Community!

Just for a better understanding of the issue, I would like to know if Confluence is enabled on Product Access and if you tried to disabled/enabled it again.

Screen Shot 2021-02-08 at 16.56.45.png

Is it happening since you first integrated your site with GSuite or it started happening after a while?

Does it show any error while or after syncing with GSuite? If it does, please share a screenshot with us (just make sure to hide private information).

Kind regards,
Angélica

Hi @Angélica Luz ,

 

Yes, Confluence is enabled on the product access page. 

Yes, I tried to disable / enable it multiple times with no success.

 

I think this is happening since I integrated with GSuite. It was never working properly.

I don't see an error popping up. Also, the log file doesn't show anything.

 

Is there any other place where I could check for additional information?

 

Screen Shot 2021-02-08 at 10.17.48 PM.png

Thank you for the details, @Mirko Schmidt.

Further investigating this issue, there is one thing that can prevent new users from getting access to Confluence: Space Permissions.

They are not automatically added when GSuite adds them to “All users from GSuite” group, but it works when you add manually the “confluence-users” group because, by default, this group has permissions.

Can you please go to Confluence and click on Cog icon > Space permissions?

On this page, click on Edit permissions and grant permission to “All users from GSuite” > Save.

Please, take your time to test and let us know how it goes.

Hi @Angélica Luz ,

Ah, that sounds reasonable. I changed the default space permissions for new spaces as well as the space permissions for all existing spaces using your advice.

I'll report back once I've added the next user.

Thanks,

Mirko

Like Angélica Luz likes this

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events