Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,260
Community Members
 
Community Events
176
Community Groups

User Provisioning with OneLogin (again)

Hi all,

I am trying to do the automated user provisioning from OneLogin to Atlassian Access and doing so with the help of this guide:

https://onelogin.service-now.com/support?id=kb_article&sys_id=05501489db792708ca1c400e0b9619ea

Everything seems to work fine and it says the user has been provisioned in the onelogin backend, however i cant pull my groups from Atlassian Acces as it shows on the picture below. I have a blank box instead. I have been through this guide about 20 times followed the steps properly. Anybody has any idea what else can be done?

 

Screen Shot 2019-03-01 at 11.17.55 AM.png

 

 

 

I have reached out to Onelogin and they have sent me this:

"Mate,

There is nothing wrong with the onelogin side. The issue is we are asking for the values from here 

https://api.atlassian.com/scim/directory/7f373c24-ab7a-4223-b2af-f2d996237663/Groups?count=100&startIndex=1 

We are getting a good response 200 Ok 

[INFO Fri Mar 01 13:32:38 +0000 2019] Response Code: 200

Yet Atlassian API is reporting back 0 results 

"{"startIndex"=>1, "totalResults"=>0, "itemsPerPage"=>100, "Resources"=>[], "schemas"=>["urn:ietf:params:scim:api:messages:2.0:ListResponse"]}"

I do not have any information other than this response showing 0 results I would recommend reaching out to TS at atlassian and find out why this call at https://api.atlassian.com/scim/directory/7f373c24-ab7a-4223-b2af-f2d996237663/Groups?count=100&startIndex=1 using your GUID 7f373c24-ab7a-4223-b2af-f2d996237663 and token is responding with 0 results. 

Best Regards"

Anybody has any ideas?

Thanks in advance

I have gotten an answer since which is this:

"

Hi Máté,

If you're setting up SCIM automatic user provisioning for the first time, your Org in Atlassian Access won't have any groups associated with it, so when OneLogin or you query the API you'll get zero groups returned. You might have groups that already exist in your Jira site, but those are in a tenant/site context and not global, so those aren't the same groups that OneLogin would pull.

To set up groups in automatic user provisioning, in your OneLogin dashboard you would go to the "Roles" tab in the "Users" dropdown. Creating these Roles corresponds to a SCIM group; you could then assign users to these roles and push the group in the parameters tab for your app as seen in OneLogin's documentation.

We'll follow up with OneLogin to clarify and update the documentation, hope this helps!"

I tried this as well but it doesnt at all still, could anybody help please? Have been waiting for this for a long time.

Thanks a lot
Best Mate

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events