getting "Cannot determine required plugins, cannot resolve bundle error"

Vijay anand June 27, 2018

To edit pdf file, i am in need of itextpdf jar. I have added the itextpdf in pom.xml file when i build plugin its seem to error. the following

SDK version : 6.3.10

itextpdf  version : 5.5.3

java version: 8.0


<!-- -->


cause Error

ERROR - 09:54:06,519 - com.atlassian.plugin.osgi.factory.OsgiPluginInstalledHelper - [localhost-startStop-1]
- Cannot determine required plugins, cannot resolve bundle 'com.web.pdf.gen'


2 answers

1 accepted

6 votes
Answer accepted
Vijay anand July 6, 2018

It's Fixed by adding, in my pom.xml


Priyadharsini.r July 6, 2018

Great Job. Working fine.

Vladimir September 19, 2018

Faced with the same problem, only when connecting to any other jar file. Please show your corrected pom.xml. Thank you in advance)

I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 7, 2020

Love you, bro. It works for me, too.

Seyid Aghayev November 16, 2020

This thing solved whole day of researching this issue. Happened when adding an external jar and using its methods

Dmitrii December 8, 2021


Scott Martindale November 8, 2023

Amazing. Thank you!!

0 votes
Aleksandr Zuevich
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
June 27, 2018


Why do you set scope provided? I think you need scope compile.

Vijay anand July 1, 2018

Hi Aleksandr,

thanks for your reply. i tired all of this (compile, provided, runtime),

1) .i have clean and run plugin,

2).my local repository has itextpdf.jar ,

3).updated version of SDK & Java.

But, Same error! i am stuck in it. My plugin not enabled. Can you help?

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events