Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,191
Community Members
 
Community Events
176
Community Groups

Confluence SSO for Data Center is encoding query parameters.

I have configured Confluence to use SSO 2.0 with the SSO for atlassian server and data center plugin.

The SSO I am using is OIDC with Keycloak.

When I go to the confluence login page, I can see the Login with IdP button, and using it successfully routes me to Keycloak login page, then redirects me back to confluence.

The problem: If I go to a confluence site or page with additional query parameters

?spaceKey=ABC&title=123

 the & will become URL encoded into & like so:

?spaceKey=ABC&title=123

And this results in a "Page cannot be found" error.

 

Any advice is appreciated, thank you!

1 answer

Sorry, Created the question in the wrong community.

Please see the question in Confluence community instead:

https://community.atlassian.com/t5/Confluence-questions/Confluence-SSO-for-Data-Center-is-encoding-query-parameters/qaq-p/1769100

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events