Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Why is JIRA Portfolio showing "Issues without Epics" when the issues are assigned to Epics?

I've been searching through Answers to see if anyone else has this same issue.  I've found:, but that doesn't explain why issues in my "create plan" show up under "issues without epics" when they clearly have an epic and fixVersion assigned?  We are not hiding fixVersion on the project or issues.  Does Portfolio use Epic Link or Epic Theme?  Is there another setting that may be getting in the way?

We're using Portfolio Live Plans v2.1.3.

15 answers

Ok, so I said I had the same problem, then inspiration hit.

In Portfolio:

> Go to "Configure "(click the elipses to the right of the board name).

> Click "Issue sources"

> Click "Edit sources"

> Run through the steps and ensure when you get to the "Epics" step, you click "Select All." 

> Then finish the configuration steps.

This fixed the issue for me.


This did not work for me. If I go there at Issue sources, I can not find the Epic that I am looking for.

So I have an issue under "issues without a parent Epic", that does have an Epic, but I can not find this Epic in the "Issue source" view you mentioned, so I cannot include it in the plan.

Do you see a solution for my problem?

Hi Jeroen, 

I had the same issue and struggled with it for a long time. For me - the reason I couldn't see the epic was that I was using the team's board for the issue source and the Epic wasn't shown on the board as the filter for the board only filtered on issues assigned to the team (and the epic wasn't assigned to the team). When I assigned the epic to the team it appeared on the team's board and then was also there in the issue source for selection. 


Like # people like this

Hi @Fiona McCrossan

Thank you for your answer!

However in issue source configuration I am using only two "Projects". 

How can I assign an Epic to a team? 

I have several of these problems, but how can I know if I have covered all Epics that were not included? I can add teams to the Epics for the ones I know they are missing in the scope view, but what about the others that I am not aware of? 


Hi @Jeroen Thoelen

That is weird, for me if I use Project as the source then I can see all the Epics ok. 

When you go in to issues sources in Step 3 ->  In top right-hand-side, can you select 'Epics' there and you should see the Epics that are in the Project. 

Otherwise I did see someone say it can be to do with Fix Version not being visible in the Epic - 



Hi @Fiona McCrossan

Thank you for your suggestions, but I already checked all the epics that are included in the plan (In the configuration part), but this does not show the epics I am looking for, so for some unclear reason they are not showed there...

For the Fix/version part, we do not work with this yet, so this cannot be the problem.


1 vote
Deleted user Mar 09, 2017

Same issue.

Same issue... 

0 votes
Pete Singleton
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Oct 10, 2019

I have just encountered this problem.  In our case, the reason the Story was appearing as having "no parent link" was because the parent Epic was marked via Fix Version as part of an Archived release.

Once I un-archived the Release, then the Portfolio Plan showed the hierarchy correctly.

I had a related issue. In my case, the Plan had a source of a special Board. That Board's filter used Labels, but also used another filter in its JQL. For some reason, although the Filter gave the results I wanted, the board refused to "see" the epics until I tweaked the JQL to explicitly include Epics (redundant with the secondary filter). 

Something about Labels? Something about using a secondary filter?


No idea why, but I got it to work finally by tweaking that Board's filter. 

So, had the same issue where Epics have children (Story) and in various stages of completion, yet Portfolio would not pick any of that up, After much looking around, I  noticed it was happening on a filter was using labels. 

Anyone else?

Does the epic get picked up in the filter with the labels ? If not make sure the epic has the same label and is included in the filter,

0 votes
Deleted user May 07, 2018

I have a slight variation on this issue.


I have a team board that brings in issues assigned to teams


I have an overall board bring in the epics and stories.


I have set up a plan with the epics I want delivered in the first 12 months.

The plan has dragged in two issues  that are part of other epics and classified them as Issues without a parent. These issues do not have any dependencies to or from issues that are in the plan


From within the plan it say that there is no Epic


No Epic.PNG



But there is definitely an Epic attached. 


I cannot work out why these have been included

You can exclude them from the plan - there's an option to do that. 

Found another related article that suggests the "Fix Version/s" field need to be visible on the Epics for Portfolio to pull them in.

I finally figured out what the problem was for why my epics weren't showing up. The actual 'Epic' itself was not assigned to the team - and the board was driven off the team field. Once I assigned the epic to the team - I could then select it and add it to the Portfolio plan. 

Facing the exact same problem. Now, that the problem is identified, how do I actually fix this on JIRA so that the Epics do reflect in my Portfolio? So, how do you assign an epic to the team?

Hi Arjit, 

We have a custom field that we use for assigning issues to teams so I was able to use that. You probably don't have that so what I suggest you do is check the 'source' that you are using to set up your plan and see if the epics show up there. I was using a Kanban board which worked off a filter and I noticed the actual epics themselves weren't on the board as the board was driven off a filter based on our custom 'Assigned team' field which wasn't set. You might find your board is based off some filter that for some reason doesn't include the epic - you then need to find a way to get epic to match that filter - if that makes sense !

Mine is based off of project.  There is only one project.  I imported everything for that given release but for some reason some items that are linked to Epics are not showing the Epic link in portfolio, and some Epics that exist are not available to link to.

Thanks Thomas,

All epics and sub-issues from the particular project involved are included (the portfolio plan is built off one project - we are in an ongoing proof of concept). I have reviewed every single issue, one by one, and checked them all. And it tells me there issues missing. I have given up completely on this; without the ability to drill through and investigate the data the use is left frustrated.

This issue of non-empowerment of the user also exists in the themes report; in the design of the schedule; and also with the lack of fundamental items in the base view such as priority (and due dates). Basically in almost every part of the product.

Please give the user the ability to control their outcomes and let this product be as good as it should be. In the meantime, if/once we have developed a progress report that can cater for multiple projects, we will stop paying for this product as it provides little value - we're just using it for experimentation at the current time.

0 votes
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Feb 04, 2018

Hi Here,


A Portfolio plan only contains and reports on what is part of the plan, this means if the epics are not included (or any other level of hierarchy above story) then the children will be marked as "without a parent"

This goes the other way as well, if you only include a parent it won't have its children.

The solution to it is to ensure the issues are part of the plan issue sources.




Hi Thomas, 

Thanks for your reply. Here's the scenario I have. I have a plan based off a team's Kanban board but the epics don't show up in the configure issue source wizard to even be able to select them. The only way I can see the epics is to add the overall Project as an issue source too. However the overall project is used by many teams across the company so when I add it in as an issue source, anything new that gets added to the project constantly gets added to my portfolio plan even if it is not part of my team's kanban board. I have also tried using a filter for the team and epic but again the epic isn't there to add in only the stories. 

The only way I can find to add the epic is to include the project. There doesn't seem to be any way to use either a filter or a board and include the epic from that. If you've any ideas on how to solve that I would be very grateful!



Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Feb 05, 2018

This is not expected but I haven't been able to reproduce that (for Portfolio for Jira Server), I'd suggest to contact support to help you sort this situation as soon as possible.






Fiona, there may be a way to add the Project where your Epics are, but only add the Epics you want.

It will take three steps:

1. Go into the Project where the Epics live and put in a Label marking the your Epics with a unique Label. For Instance: Fionas

2. Create a filter that pulls only Epics from that Project that says: Project = X and Labels = "Fionas".  (Edit the Permissions of the filter so it is shared.)

3. Create a Board that is built off of that filter.  Then add that Board as a Source for your Portfolio Plan.

This way can still have your Data Source but not all the brothers and sisters of your Epics.

Same issue. Only way I've found to get them to show is to also add the overall Project that the epics are in so e.g. I have a plan based off a team's board and the epics don't show up. If I include the project that the epic is in the epic appears but the downside to it is that anything that is new that gets added to the project also gets added to the plan so you have to keep going into the scope and excluding the issues that aren't relevant to your plan. 

Same issue. How on earth can something this fundamental be broken and no-one has acknowledged it, no-one has explained how it is going to be fixed, and no-one has given a workaround for it? Why is it not possible to drill into any of these reports and see the underlying data?

I am not sure we'll be able to keep this product, it may be simpler just to build our own reports.

Same issue. It is driving me crazy.

Deleted user Jun 23, 2021

SAME! :(

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events