Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,465,131
Community Members
 
Community Events
176
Community Groups

Remove the Epic Link on a User Story

Hi There:

I have a User Story, that I now want to simply remove the Epic Link, all of the previously read posts do not seem to work.

Any suggestions would be greatly appreciated.

Thanks, have a great day.

Mike

5 answers

5 accepted

1 vote
Answer accepted

@Mike Lemmon - Thanks for your updates.

Best, Joseph

1 vote
Answer accepted

Joseph, Vero:
Thanks for your responses.

It ends up it is a level of integration that was built by our group to automatically create an Epic, whenever a User Story was being created under a Feature, to create the Feature, Epic, User Story relationship.

I need to remove the Link to the User Story from the Feature and the Epic.

Thanks again, have a great day.

Mike 

1 vote
Answer accepted

Hi @Mike Lemmon 

 I don't quite understand your question, but it is as easy as editing the story and removing the epic link that you have placed in the field by clicking on the "X" in it.

 Unless you have another problem or do not see the "Epic Link" field

Regards

Hi Vero, when I look at the Epic Link, there is no "X" to delete it.  If I blank it out and click on the check mark, the original Epic Link .. reappears .. argh...

1 vote
Answer accepted

@Mike Lemmon - You should go to the user story in the Jira project and manually delete the EPIC LINK (see example screenshot).  Afterward your AR plan should reflect the change.

This is assuming that you have the permission to edit the user story in the Jira project. 

NOTE -AR Plan's input source is from your Jira project/board.

Hope this helps.

Best, Joseph Chung Yin

Jira/JSD Functional Lead, Global Infrastructure Applications Team

Viasat Inc.

 

2020-11-18_12-31-59.png

Hey Joseph:

I did try this and it keeps reappearing..

What lack of authority could be causing this? ... As I'm the administrator for our JIRA instance, I did not think it was an authority issue

Thanks  

0 votes
Answer accepted

@Mike Lemmon -

Forgot to mention that you can also do this within your AR plan.  You have to expose the "Parent" field in your plan.  If you don't see it, then click on the Fields button to add it to your plan.

Once you plan is showing the field column, then you can go to the user story issue and click on the "x" button to remove the link to the Epic.   Remember, you will need to commit your change, so it can be pushed back to the Jira project.  Otherwise, it is only local to the AR plan.

See attached image for your reference -

Best, Joseph

2020-11-18_12-57-19.png

Hey Joseph:

After I complete all of the steps you identified .. the Epic Link, under Parent .. reappears .. Argh... 

Any thoughts what is causing this to happen?

Could it be some authority issue???

Thanks, have a great day.

@Mike Lemmon - Remember you will have to commit the changes back to the Jira project after you remove the link in your AR plan. Otherwise the AR plan will refresh itself with what's is coming from the source.  (see screenshots below)

2020-11-19_7-22-39.png2020-11-19_7-22-22.png

 

You will also need to check if you have the proper rights (edit issue) against the source Jira project.  

Hope this helps.

Best, Joseph

@Mike Lemmon In addition checking your permission to the source project, you will also need to make sure that you have the Edit right to the AR Plan itself.  You need to click on the clog wheel symbol (on the right of your AR plan's name) and select the "Configure" option.  From there you need to check on the "Permissions", make sure you are part of the users that have Edit right to the plan.

2020-11-19_7-27-52.png

Best, Joseph

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events