Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Hi guys

 

I'm trying create behaviors code in my instance.

But my system doesn't work.

When I fill the name and description to create behavior, nothing happens.

 

 SHould I do configure anything to behavior works?

 

Tks a lot.

 

Regards

1 answer

1 accepted

0 votes
Answer accepted

Hello Karla,

What do you mean by nothing happens ?

 

When you fill name and description then click the Add button.
Your new behaviours should appear at the end of the list of behaviours right on top of the form.

 

Regards,

 

Adrien

Hi Adrien,

 

yeah, nothing happens

:((

 

I click in the "add" buttom... but the behaviour doesn't appear in the screen.. and no error message is showed in the scrren.

 

The action of clicking in the "add" buttom, doesn't work.

 

I tried disable add-on and enable again right now. but it doesn't work too. 

:((

Can you look in the javascript console of your web browser if there is any error when clicking Add ?
(You can open the console by pressing F12 in most of web browser)

Hi Adrien,

 

this message was showed for me.

 

batch.js?healthcheck-resources=true&is-server-instance=true&is-system-admin=true&locale=en-US&nps-acknowledged=true&sd_operational=true:9 Mixed Content: The page at 'https://preprod-portal.viavarejo.intelipost.com.br/secure/admin/Behaviours!default.jspa?' was loaded over HTTPS, but requested an insecure resource 'http://preprod-portal.viavarejo.intelipost.com.br/rest/scriptrunner/behaviours/latest/admin/behaviour'. This request has been blocked; the content must be served over HTTPS.

 

Do you know how to solve?

 

Regards

From this error it is not the "Add" button which does not work, it is the AJAX request to the REST API to retrieve existing Behaviours which use the wrong protocol.
Your server and Jira use HTTPS secure protocol but the page tries to call the REST API using HTTP unsecure protocol, your web browser blocked this.

I does not know how this is managed by Jira and Script Runner. I don't know if it is a configuration problem or not.

I have one idea, if SR use the Base URL settings to generate the address for the REST API call:

  • Look in Administration > System > General configuration.
  • In General settings you have the "Base URL" field.
  • The adress should be https://preprod-portal.viavarejo.intelipost.com.br 
  • Be careful of the https:// there is an s before "://"

If this is already the case, I think you should ask for Adaptavist support.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Statuspage

New feature: Slack notifications for Statuspage

We're excited to announce the release of a long-requested feature on Statuspage. Now visitors to your status page can subscribe to get notified in Slack when you report an incident or maintenance. Th...

81 views 0 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you